3

If i set up my keys in Ubuntu as Alt+Shift for change input method, it is conflict with "Hud" in Firefox wich try "open" menu. Its very annoining behavior, and i cant normally type on 2 languages.

i've already install add-on from Mozzila help link ( https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly ) , that can customize shortcuts, but i cant find there only this option with "Alt" all another exist. Also when i change inputs this bug make a new-line in comments on vk.com site so i need delete it ;(((

OS: ubuntu 16.04 server + gnome Firefox 52.0.2 (64-bit)

5

Found answer: type in adres bar about:config Hit Enter. Click Yes. Then click on search string on this page. Type this (or paste it): ui.key.menuAccessKeyFocuses

Then click on "true" to make it "false". Done, now when you push "Alt" key in firefox, menu dont appears and u can easy change language or make another action with Alt key.

Gratz!

  • 1
    FYI there is a bug 1712200 with Firefox on Wayland. – N0rbert Nov 4 '17 at 21:21
  • 2
    Sometimes menu bar in Firefox is helpful, so disabling it is not an ideal solution. – user502144 Jan 3 '18 at 11:12
  • @user502144 sometims its like one time in century or 1000 years? :) I dont use this menu bar sience 2003-2005 year. All settings i have in small menu, if i need save or something else i remember hotkeys. btw now in 18.04 no this annoying behavior. only if i push one alt menu appears. – Amaroc May 11 '18 at 20:15
  • 1
    @Amaroc So, how do you restore previous session after something went wrong? The only option I see is in menu bar. By the way you can use F10 instead of Alt to open menu bar, so this answer seems to work. – user502144 Jun 11 '18 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.