1

I am using Xubuntu 16.04 exclusively on an old MacBook from 2007.

My keyboard is Portuguese. In Settings/Keyboard/Layout I defined the keyboard model as MacBook, Change layout option as Left-Alt and Composer key as Right-Alt. I tried also several 3rd level keys without any luck. Normally in the Portuguese keyboard I will get the "at sign" symbol using Left-Alt 2.

Now the only way was to do Ctrl+Shift+U+40 to get the @. I am aware that there are similar questions but with the exception of this answer none have worked.

$ setxkbmap -query -v 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules: evdev
model: pc105
layout: pt
variant: mac
Trying to build keymap using the following components:
keycodes: evdev+aliases(qwerty)
types: complete
compat: complete
symbols: pc+pt(mac)+inet(evdev)
geometry: pc(pc105)
rules: evdev
model: pc105
layout: pt
variant: mac
6
  • Please run the command setxkbmap -query -v 10 in a terminal window and show us the output by editing your question. – Gunnar Hjalmarsson Apr 23 '17 at 20:04
  • Here is the output: Setting verbose level to 10 locale is C Trying to load rules file ./rules/evdev... Trying to load rules file /usr/share/X11/xkb/rules/evdev... Success. Applied rules from evdev: rules: evdev model: pc105 layout: pt variant: mac Trying to build keymap using the following components: keycodes: evdev+aliases(qwerty) types: complete compat: complete symbols: pc+pt(mac)+inet(evdev) geometry: pc(pc105) rules: evdev model: pc105 layout: pt variant: mac – sbac Apr 23 '17 at 20:53
  • I added the output to the question for better formatting. Based on the info you provide, I miss a few things. Possibly it would behave more like what you want if you run this command: setxkbmap -option "lv3:lalt_switch,lv3:ralt_alt,compose:ralt" – Gunnar Hjalmarsson Apr 23 '17 at 22:22
  • Yes now is almost fine. I get @ with Alt+2. The only exception is with Alt+3: I get a £ instead of an Euro. A sign of times? – sbac Apr 23 '17 at 22:30
  • You access the € symbol via <Alt>+E with the keyboard layout you are using. Please also see the answer I posted. – Gunnar Hjalmarsson Apr 23 '17 at 22:46
0

To make the XKB options I proposed in a comment persistent (i.e. preserved when rebooting), you can open the /etc/default/keyboard file for editing and change the line

XKBOPTIONS=""

to

XKBOPTIONS="lv3:lalt_switch,lv3:ralt_alt,compose:ralt"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.