7

Using a fresh install 17.04 lUbuntu

Fairly new to Ubuntu and as often is my problem any help I try to find is way more advanced than I can follow.

I'm trying to use test my AMD R9 290 card for mining using Genoils miner. I tried it on Windows before installing Ubuntu and that worked fine.

The problem is when I try to get it working I get this error:

[OPENCL]:No OpenCL platforms found
[OPENCL]:
Listing OpenCL devices.
FORMAT: [deviceID] deviceName

I know at least some OpenCL related packages are installed.

As I understand it I should use an open source driver called AMDGPU instead of AMD's driver. But I can't figure out if it's already installed or if not how to install it. The AMDGPU page mentions some xf86-video-amdgpu that I get "unable to locate" on.

I tried AMD's own proprietary driver and with that installed OpenCL works but I then get an error that i have the wrong DRM version: "amdgpu_device_initialize: DRM version is 2.45.0 but this driver is only compatible with 3.x.x." As I understand it AMDGPU uses 3.x.x while AMD's own driver uses 2.x.x.


So from what I've found out you can use this command to check if you're using the open source AMDGPU

lspci -nnk | grep -iA2 vga

If the kernel driver in use says "radeon" rather than "fglrx" it's using AMDGPU.

I blacklisted AMD's driver using the instrucitons on the AMDGPU page:

/etc/modprobe.d/radeon.conf

blacklist radeon

(Although I find it a bit odd that it here should say "blacklist radeon" while the kernel driver (using the command above) should report "radeon" with AMDGPU)

Anyway I was still unable to get it to work with OpenCL. OpenCL still reported no devices. From what I've learned this seems to be because many things including OpenCL aren't fully supported on newer Ubuntu versions like my 17.04. Best might be Ubuntu 14 for this.

In the end I took the easy way out and installed Windows 10 using an old key :f When I get some more time I will try again using an old Ubuntu release and see if I can get it working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.