0

I just did a fresh install of Ubuntu 16.04 on a desktop computer. During the installer, the auto network script failed so I configured it manually (entered my own IP, entered in the subnet mast, entered in the default gateway) and everything was okay with no problems. It connected successfully and finished the install.

Now that it's installed, I'm not getting any network connectivity - I can't even ping the gateway. I'm using wifi and am unable to use ethernet. ifup/ifdown on enp2s0 doesn't have an issue. I tried with DHCP, but DHCP just hanged and didn't solve it either. I also verified the requested IP address wasn't in use on the network.

root@ubuntu:/home/liam#  lshw —class network 
*—network 
    description: Ethernet interface 
    product: RTL8111/8168/8411 PCI Express Gigabit Ethernet 
    vendor: Realtek Semiconductor Co., Ltd. 
    physical id: O 
    bus info:  pci@0000:02:00.0
    logical name: enp2s0 
    version: 06 
    serial: b8:97:5a:32:c1:5f
    size: 10Mbit/s 
    capacity: 1Gbit/s 
    width: 64 bits 
    clock: 33MHz 
    capabilities: pm msi pciexpress msix vpd bus_master cap_list 
    configuration: autonegotiation=on broadcast=yes driver:r8169 
    resources: irq:25 ioport:d000(size=256) memory:f0004000-f000 
*-network DISABLED 
    description: Wireless interface 
    physical id: 1 
    bus info: usb@1:2
    logical name: wlxec086b1eaf1b 
    serial: ec:O8:6b:1e:af:1b 
    capabilities: ethernet physical wireless 
    configuration: broadcast=yes driver:r8188eu multicast=yes

Output of /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface 
auto lo 
iface lo inet loopback 

# The primary network interface 
auto enp2s0
iface enp2s0 inet static 
        address 192.168.1.200
        netmask 255.255.255.0 
        network 192.168.1.0 
        broadcast 192.168.1.255 
        gateway 192.168.1.254 
        # dns-* options are implemented by the resolvconf package
        dns-nameservers 192.168.1.254 
        wpa-ssid ATT548CA 
        wpa-psk frank777

#auto enp2s0
#iface enp2s0 inet dhcp 
#       wpa-ssid ATT548CA
#       wpa-psk frank777 

EDIT: Wireless Info Script results: http://paste.ubuntu.com/24446060/

  • 1
    Welcome to AskUbuntu! Could you please run the network diagnostics and edit your question to include a link to the result? I know it may seem a bit overwhelming for a novice but your info so far is a bit vague and the diagnostics will likely cover all options that may cause your issue. Thanks. – David Foerster Apr 23 '17 at 17:56
  • Thanks David, I've gone ahead and added a link to a paste with the results. – Liam Smith Apr 24 '17 at 5:12
  • Ended up getting network connectivity to work after installing wpa-supplicant and dependencies from a USB. Question is solved. – Liam Smith Apr 24 '17 at 7:37
0

First, your file is faulty in several respects. First, although you say you want to use wireless, your interface, enp2s0, is for ethernet. The correct sequence for wireless is:

# The loopback network interface 
auto lo  
iface lo inet loopback 

# The primary network interface  
auto wlxec086b1eaf1b  
iface wlxec086b1eaf1b inet static  
address 192.168.1.200 
netmask 255.255.255.0  
gateway 192.168.1.254
# dns-* options are implemented by the resolvconf package
dns-nameservers 192.168.1.254 8.8.8.8
wpa-ssid ATT548CA 
wpa-psk frank777

Next, restart the interface:

sudo ifdown wlxec086b1eaf1b && sudo ifup -v wlxec086b1eaf1b

Check to see if you connected:

ping -c3 192.168.1.254
ping -c3 www.ubuntu.com
|improve this answer|||||
  • Hi, thank you for the reply! I included the wpa-* sections because that's what a different thread suggested, I am using wireless and not ethernet so wouldn't I need it? Also, I thought network manager was unavailable on Ubuntu Server? I'll go ahead and try your config and come back with the results. – Liam Smith Apr 23 '17 at 23:39
  • Your question was not clear to me as to whether you wanted wireless or ethernet. I will revise my answer accordingly. – chili555 Apr 24 '17 at 0:03
  • Running ifdown returns "interface wlxec086b1eaf1b is not configured", and running ifup returns "RTNETLINK answers: File exists. Failed to bring up wlxec086b1eaf1b". I've tried adding wlxec086b1eaf1b=wlxec086b1eaf1b to /run/network/ifstate, however that doesn't change the results. Thank you! – Liam Smith Apr 24 '17 at 4:44
  • A reboot seems to have fixed the ifup/ifdown errors I just mentioned, however even while it's not outputting an error I still am not getting connectivity. ifup, ifdown, and ping output. However, in lshw -class network it is showing the wifi interface as not disabled anymore, so it looks like we've made progress! – Liam Smith Apr 24 '17 at 4:54
  • May we see: dmesg | grep wlx and also: iwconfig – chili555 Apr 24 '17 at 13:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.