0

My Asus x55u cannot use its battery. Power statistics say the battery is at 0% and charging, 0 seconds till full/empty, and when the power cable is unplugged it immediately dies. (No shutdown)

However, Ubuntu does recognize the battery (the power indicator is red, the info says present: yes) if the battery is connected.

This leads me to believe it's not just a hardware problem.

Also, Ubuntu acts unexpectedly. I had this problem on Ubuntu 12.04, before upgrading to 14.04. On 12.04, the menu bar indicated (not present). After upgrading to 14.04 the problem persisted but the indicator light was flashing. I tried lots of changes to the /etc/default/grub file, and restarted the computer in different ways, and now the indicator light is again constantly red. The menu bar now shows only the icon of a charging battery.

I find the info and state of my battery especially weird:

$ cat /proc/acpi/battery/BAT0/info 
present:                 yes
design capacity:         49500 mWh
last full capacity:      10021 mWh
battery technology:      rechargeable
design voltage:          10800 mV
design capacity warning: 4950 mWh
design capacity low:     495 mWh
cycle count:             0
capacity granularity 1:  495 mWh
capacity granularity 2:  495 mWh
model number:            K55--44
serial number:
battery tipe:            LIon
OEM info:                ASUSTek

$ cat /proc/acpi/battery/BAT0/state
present:                 yes
capacity state:          critical
charging state:          charging
present rate:            0 mW
remaining capacity:      0 mWh
present voltage:         7618 mV

Any help would be GREATLY appreciated!

2
  • Have you tried a battery check via the Bios to verify it really is no hardware problem? It sure sounds like one.
    – Bruni
    Commented Apr 23, 2017 at 16:55
  • To second what Bruni said, everything I see, especially in bat info and state, leads me to believe the battery is bad.
    – nullmeta
    Commented Apr 23, 2017 at 18:38

0

You must log in to answer this question.

Browse other questions tagged .