The volume changing steps in Ubuntu Unity 17.04. are about 6% from step to step. The question is to change them to 2% per steps.


After following the steps in the answer below, it changes 2% volume with the keyboard-buttons, but the slider (volume-indicator) stays at 6% per steps.

Is there any way to set the slider to 2% too?

1 Answer 1


First portion of this Answer is taken from here originally posted by Geppettvs D'Constanzo

This command will add 2 percent volume in your existing volume settings

amixer -D pulse sset Master 2%+

and this will reduce it

amixer -D pulse sset Master 2%-

You can also make it 1 percent if you want even granular control over volume and can also add keyboard shortcuts for these commands to use them without terminal and in a reliable way.

Another approach

This is system wide and will not change the workflow (like remembering new custom shortcuts) but for this you'll need to add a PPA to your system to make it work, How to Use a PPA?

sudo add-apt-repository ppa:george-edison55/gnome-settings-daemon
sudo apt-get update
sudo apt-get install unity-settings-daemon

and run upgrade (just in case)

sudo apt-get update
sudo apt-get upgrade

You will need to restart after installation completes. Once the packages have been upgraded, you can use the dconf command to change the volume increment:

dconf write /org/gnome/settings-daemon/plugins/sound/volume-step 2

(The default value is 6.)

Now when you press the volume keys, the volume level should change in increments of 2

Radical Step

Use Ubuntu Gnome 17.04 (or Gnome DE)

What is Default Behaviour of gnome desktop?

this is my output of amixer get Master | grep Mono right now

Playback channels: Mono
Mono: Playback 53 [72%] [-21.00dB] [on]

Output says my volume is now 72% percent, Now I go to the volume slider in Gnome and slide it by just one tick (scroll(er) tick) and now my output is

Playback channels: Mono
Mono: Playback 54 [73%] [-20.00dB] [on]

Notice that it changed just 1 percent, that's as fine as it gets.

another thing that I want to point out it is that it (this feature) looks really important to you and if you're willing to take this radical step then their are few major advantages you're looking at

  1. Unity is already dead, so new patches will most probably not release
  2. Gnome is gonna be default desktop on Ubuntu 18.04 and beyond making it a good contender to try in 2017
  3. It also gives you an early preview of things
  4. and Gnome is really good (personal opinion)

How to install Gnome Shell?

sudo apt install gnome-shell

you'll have an option to choose between Unity and Gnome shell

How to get full Ubuntu Gnome 17.04?

Here you go

More info on Gnome shell

  • Thanks a lot for the quick answer. I mostly use my mouse to change the volume above the volume-indicator. Is there any way to set this step-setting to 2% too?
    – amDude1848
    Apr 23, 2017 at 14:42
  • 1
    Okay, thanks a lot so far. I will wait for an answer that maybe fix it, than i will mark it at solved.
    – amDude1848
    Apr 23, 2017 at 14:50
  • 1
    Thanks a lot for the new answer! :-) That works well for the keyboard-volume-buttons, but unfortunally not for the voloume-indicator if i change the volume above the indicator with the mouse wheel. Maybe it has to do with the scrolling-speed of the mouse. But it's okay like this - i marked it as solved. Thanks again! :-)
    – amDude1848
    Apr 23, 2017 at 15:21
  • In the other slider if i click the volume-indicator it unfortunally don't work too. :-(
    – amDude1848
    Apr 23, 2017 at 15:31
  • 1
    Yes, i did. I think i will change to gnome soon. RIght now i spent a lot of time to configure my Unity-system, so i don't like to delete it from today to tomorrow, but in a longer sight i have no other decision. Thanks again for your solutions and explanations in this thread.
    – amDude1848
    Apr 24, 2017 at 11:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .