0

This question already has an answer here:

I recently installed a video converter software and later I removed it.

After removing it, I can't seem to install any other software. It seems when I removed the video converter software, it also removed some library that is necessary for other software to be installed, too.

Now, I want to install monodevelop, but it again notifies so much dependencies!

Here is what my terminal says:

$ sudo apt-get install monodevelop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 mobilemediaconverter:i386 : Depends: libglib2.0-0:i386 (>= 2.2.0)
                             Depends: libgtk2.0-0:i386 (>= 2.2.0)
                             Depends: mencoder:amd64
 monodevelop : Depends: gnome-icon-theme (>= 1.1.3) but it is not going to be installed
               Depends: monodoc-manual (>= 1.1.9) but it is not going to be installed
               Depends: mono-runtime-sgen but it is not going to be installed
               Depends: mono-xbuild but it is not going to be installed
               Depends: mono-runtime (>= 3.0~) but it is not going to be installed
               Depends: libgconf2.0-cil (>= 2.24.0) but it is not going to be installed
               Depends: libglade2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
               Depends: libglib2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
               Depends: libgnome-vfs2.0-cil (>= 2.24.0) but it is not going to be installed
               Depends: libgnome2.24-cil (>= 2.24.0) but it is not going to be installed
               Depends: libgtk2.0-cil (>= 2.12.10-1ubuntu1) but it is not going to be installed
               Depends: libmono-cairo4.0-cil (>= 4.0.4.1) but it is not going to be installed
               Depends: libmono-corlib4.5-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-microsoft-build-engine4.0-cil (>= 3.2.1) but it is not going to be installed
               Depends: libmono-microsoft-build-framework4.0-cil (>= 3.6.0) but it is not going to be installed
               Depends: libmono-microsoft-build-utilities-v4.0-4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-sharpzip4.84-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-componentmodel-dataannotations4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
               Depends: libmono-system-core4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-system-data-services-client4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-data4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-system-design4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-drawing4.0-cil (>= 3.0.6) but it is not going to be installed
               Depends: libmono-system-numerics4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-runtime-serialization4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-system-runtime4.0-cil (>= 2.10.1) but it is not going to be installed
               Depends: libmono-system-security4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-servicemodel4.0a-cil (>= 3.2.3) but it is not going to be installed
               Depends: libmono-system-web-mvc3.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web-razor2.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web-services4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-system-web-webpages-razor2.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-web4.0-cil (>= 2.10.3) but it is not going to be installed
               Depends: libmono-system-windows-forms4.0-cil (>= 1.0) but it is not going to be installed
               Depends: libmono-system-xaml4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-system-xml-linq4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-system-xml4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-system4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libmono-windowsbase4.0-cil (>= 4.2.0) but it is not going to be installed
               Depends: libwebkitgtk-1.0-0 (>= 1.3.9) but it is not going to be installed
               Depends: monodoc-base (>= 3.2.1) but it is not going to be installed
               Recommends: libglade2.0-cil-dev but it is not going to be installed
               Recommends: libgtk2.0-cil-dev but it is not going to be installed
               Recommends: mono-devel but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Please, can you give me any solution to the problem.

marked as duplicate by Ravexina, Ketan Patel, Fabby, Community Apr 24 '17 at 8:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you done: apt-get -f install ? – George Udosen Apr 23 '17 at 12:39
  • Not really a dupe of that. – Zanna Apr 24 '17 at 5:38
1

If you read the output from apt it says:

...Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:......
E: Unmet dependencies. Try 'apt-get -f install' with no packages

From man apt-get:

   -f, --fix-broken
       Fix; attempt to correct a system with broken dependencies in place.
       This option, when used with install/remove, can omit any packages
       to permit APT to deduce a likely solution. If packages are
       specified, these have to completely correct the problem. The option
       is sometimes necessary when running APT for the first time; APT
       itself does not allow broken package dependencies to exist on a
       system. It is possible that a system's dependency structure can be
       so corrupt as to require manual intervention (which usually means
       using dpkg --remove to eliminate some of the offending packages).
       Use of this option together with -m may produce an error in some
       situations. Configuration Item: APT::Get::Fix-Broken.

After that, I can suggest you try:

sudo apt-get build-dep monodevelop

Apt will search for all dependencies related to monodevelop.

After that,

sudo apt-get install monodevelop

Ultimately, you can check everything you're looking for with

sudo apt search packagename 

To search repositories for packagename.

sudo apt show packagename

To show detailed description of the packagename.

You can simulate the apt-get process by using

sudo apt-get -s install packagename

and

sudo apt-get -s build-dep packagename

From man apt-get:

-s, --simulate, --just-print, --dry-run, --recon, --no-act
       No action; perform a simulation of events that would occur based on
       the current system state but do not actually change the system.
       Locking will be disabled (Debug::NoLocking) so the system state
       could change while apt-get is running. Simulations can also be
       executed by non-root users which might not have read access to all
       apt configuration distorting the simulation. A notice expressing
       this warning is also shown by default for non-root users
       (APT::Get::Show-User-Simulation-Note). Configuration Item:
       APT::Get::Simulate.

"Now, I want to install monodevelop, but it again notifies so much dependencies!"

Dependencies are usually a must, but sometimes can be omitted when they are referred to as Recommends.

From man apt-get

   --no-install-recommends
       Do not consider recommended packages as a dependency for
       installing. Configuration Item: APT::Install-Recommends.

Generally, it is good to build-dep then install package.

Get in the habit of using the man pages.

From shell type:

man command

and read.

  • thanks , I used this "apt-get -f install" as it is a duplicate question.. but thanks for the response – Battle Hawk Apr 24 '17 at 8:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.