83

How can I get the middle mouse button to behave correctly in Ubuntu? Clicking the middle button does not show the arrow which allows me to scroll the page by moving the mouse.

Information:

  1. Firefox 3.6.8
  2. Mouse: Microsoft Intellimouse Explorer 3.0
122

Edit ➜ Preferences ➜ Advanced ➜ Check 'Use autoscrolling'

enter image description here

5
  • Works for me only if smooth scrolling is disabled.
    – Somebody
    Dec 17 '13 at 15:06
  • 3
    Worked for me even with smooth scrolling enabled. Kubuntu 14.10 Firefox 29. Really usefull when using a stylus!
    – user69112
    Jun 17 '14 at 20:00
  • 1
    Great to know this can be switched off.
    – Harald
    Sep 17 '17 at 8:33
  • 1
    In about:config this is listed as general.autoScroll - To be set to true to activate.
    – FelixJN
    Feb 10 '19 at 14:19
  • 2
    I've been clicking my middle mouse button like a fool for days trying to scroll. I finally decided to look it up. Why the heck was it disabled on Ubuntu to begin with?!
    – ADJenks
    Jun 15 '19 at 18:50
20

Edit 2020-11-23: this answer is verified with Firefore 62.0.3

Edit 2018-03-14: this answer is verified with Firefore 58.02

Just to precise, since version 57 of Firefox the path is the following: Menu ➜ Preferences ➜ General, then all the way down in the Browsing section check the box Use auto scrolling.
You can also just type auto in the search field once you're in the Preferences window.

See this screenshot:

Activation of the auto scrolling with the middle button of the mouse

1
  • Works also in Firefox 83.
    – Rob Bar
    Nov 20 '20 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.