14

My notebook with Intel+Nvidia card can't resume after suspend. I have Kubuntu 17.04 installed with 4.10.0-19 kernel. I'm using Intel GPU (Nvidia driver is not even installed). This issue has been existing with 16.10, too.

When I try to resume after suspend, everything freezes at the half visible login screen. Even keyboard doesn't work (when I press CapsLock or NumLock, LEDs doesn't light up)

Any help with examining the issue is appreciated.

Edit: Suspend log can be found here: https://pastebin.com/Ere0JRwF

Edit: dmesg | less output can be found here: https://pastebin.com/zx3QQYVG

  • Hi. Can you open a terminal and run pastebinit /var/log/pm-suspend.log and then edit your question to include the link that generates. – sempaiscuba May 6 '17 at 13:31
  • @sempaiscuba It gives me the error "there is no such file or directory" (although it just happened 1-2 days ago when I accidentally put my computer to sleep) – omerfdgn May 6 '17 at 13:41
  • OK, that's no problem. Just run sudo PM_DEBUG=true pm-suspend and that should create the file. Note that this will suspend your computer, so you'll probably see the problem again. The pm-suspend.log log-file should be there when you re-start. – sempaiscuba May 6 '17 at 13:50
  • 1
    The Ubuntu Wiki has a lot of background on debugging KernelSuspend – sempaiscuba May 6 '17 at 13:52
  • 1
    "I can't wake up from sleep" would make a better title :D – Anwar May 13 '17 at 6:57
5

Solution: Upgrade to kernel 4.13.1.

I was struggling with this issue on my Lenovo G40 laptop since 2 years. Recently I upgraded to the latest kernel 4.13.1. The problem solved 100%. Works perfectly. Tested with Ubuntu 16.04, Ubuntu 17.04, CentOS 7, Fedora 26, Linux Mint 18.2, OpenSuse 42.3. All OS work perfectly with kernel 4.13.1. When I close and open the laptop lid, it wakes up from suspend smoothly.


ukuu --- Ubuntu Kernel Upgrade Utility:

sudo apt-add-repository -y ppa:teejee2008/ppa
sudo apt-get update
sudo apt-get install ukuu

http://www.teejeetech.in/p/ukuu-kernel-upgrade-utility.html

  • I have installed Kubuntu again and now it works. Great! – omerfdgn Dec 9 '17 at 17:04
5
+50

As a first step, to diagnose problems with suspend, you will want to look at details in the log-file /var/log/pm-suspend.log


If the log-file /var/log/pm-suspend.log doen not exist, just run sudo PM_DEBUG=true pm-suspend in a terminal window. NOTE: This will suspend your computer, so you're probably going to see the problem again, however, the pm-suspend.log log-file should be there when you eventually re-start.


The file should contain a series of

[...] service [servicename] suspend suspend 

statements (together with hook status messages & other useful stuff), followed by a series of

[...] service [servicename] suspend resume success

statements.

However, somewhere along the way, one or more of these will probably return an error and at that point suspend is inhibited. You may see a series of suspend changes being rolled back. To locate the problem you'd normally just need to identify which service call is throwing the error.

In this case, the log file doesn't seem to have any service [servicename] suspend resume statements, so as a next step, can you suspend the notebook again, and try to resume by pressing the power button. Give it a couple of minutes, and if it fails to re-start re-boot by holding the power button down for 5 seconds. When you re-start, open a terminal and run dmesg | less. Please update the original question to include the output from dmesg | less.

I'd also suggest verifying that your swap-partition is correctly set, and in particular that it is at least at big as your installed RAM. This is a handy FAQ on Swap.


UPDATE: The output from dmesg | less that you posted includes the line:

[    1.197601] PM: Hibernation image not present or could not be loaded.

(line 574 in the file) Again, this suggests a problem with hibernation (suspend-to-disk), but if you're sure that your problem is actually with suspend (i.e. suspend-to-RAM) then that can't be it. I also can't see any reported problems with your Intel/NVIDIA graphics.

  • 1
    Why would suspending need a swap partition? – omerfdgn May 6 '17 at 17:36
  • @farukdgn Suspend writes out the contents of your RAM (which is normally volatile memory) to the swap partition before turning off the machine. Otherwise, it couldn't restore the system when you press the power key. – sempaiscuba May 6 '17 at 18:03
  • It's hibernation, not suspend. – omerfdgn May 6 '17 at 18:13
  • @farukdgn Please read the Why do I need swap? section of the FAQ on Swap (the link I posted in the answer). – sempaiscuba May 6 '17 at 18:19
  • My problem is about suspend (suspend to RAM) as it is mentioned in the question, not hibernation. – omerfdgn May 6 '17 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.