16

When I used Unity, I remember seeing the setting for the Sticky Edges in Settings -> Displays, but I can't find that option in Gnome. Where can I turn on/off Sticky Edges in Gnome?

  • Try fiddling with some options in the Compiz Config Settings Manager from the package compizconfig-settings-manager. – Nicholas Stommel Nov 25 '17 at 23:29
  • on a dual screen setup, if you have the dock on the right screen with 'auto-hide' it can act like a sticky edge. just move the dock to the left most screen - or disable autohide – Tom Carchrae Jan 28 '19 at 18:51
8

Sorry for the late answer, but better late than never?

The setting you are looking for can be done graphically in dconf, navigating to "/org/gnome/shell/overrides" and toggling the value "edge-tiling", as appears below:

enter image description here


To do this using a CLI, enter the command

gsettings set org.gnome.shell.overrides edge-tiling false

to turn off the tiling at the edge of the screen, or

gsettings set org.gnome.shell.overrides edge-tiling true

to set it back on.

  • No issue with the late answer :-) however, I don't have the /org folder. :( – Pedro Gordo Nov 28 '17 at 17:32
  • @sedulam Which version of Ubuntu are you running? – Charles Green Nov 28 '17 at 17:39
  • @sedulam I checked 14.04, 16.04 and 17.10 - the org folder is present in all of these... – Charles Green Nov 28 '17 at 18:41
  • I installed the 16.04.3 with Gnome, could that be it? These are the folders I have: bin/ etc/ lib/ mnt/ run/ sys/ boot/ home/ lib64/ opt/ sbin/ tmp/ cdrom/ lost+found/ proc/ snap/ usr/ dev/ media/ root/ srv/ var/ – Pedro Gordo Nov 28 '17 at 19:02
  • @sedulam Ah - I have confused you! Start the program dconf-editor -> the paths for the settings are inside that program (not directories on your disk) – Charles Green Nov 28 '17 at 19:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.