10

I have connected to my wifi correctly but I cannot seem to search for anything as it just says "Server Not Found". Other computers on the same network can still search the internet though.

This has been flagged as a duplicate of Ubuntu GNOME 17.04: wi-fi not working -- mac address keeps changing? However the solution used I have already attempted and it has failed to reconcile my issue

4

I had the same issue here.

I resolved it by adding a DNS server address for the connection.

Screenshot

  • Brilliant, however I am not very well versed in what looks like German? How would I go about this? – Blue Dabba Dee Apr 22 '17 at 14:19
  • It's dutch. You click on the wifi symbol, then edit connections. Then go to ipv4 settings and type in the DNS adres of your ISP – Detlef Apr 22 '17 at 14:20
  • Okay I'll give it a go. Sorry for any offence – Blue Dabba Dee Apr 22 '17 at 14:21
  • No problem ,hope it works for you. P.s. you can use google's DNS 8.8.8.8 or 8.8.4.4 too – Detlef Apr 22 '17 at 14:23
  • Another note if you are trying to connect to a public Wifi: I had this issue that when I was trying to Sign in (in this case to Starbucks Wifi), I would get a DNS lookup error for secure.datavalet.io, so I had to redirect it to my default gateway IP address, so I add it to my /etc/host. – Hooman Nov 23 '17 at 19:15
12

This was Originally posted by Mike_IronFist over here

All you need to do is Open a terminal by pressing Ctrl + Alt + T and run:

gksu gedit /etc/NetworkManager/NetworkManager.conf

At the bottom of this file, copy and paste the following:

[device]
wifi.scan-rand-mac-address=no

Your final results should look something like this: Configuration file to allow USB Wifi to work in Ubuntu 17.04

Then just save and close the file and run:

sudo service network-manager restart

And wifi should work again!


(if above steps doesn't help)

you should also know that Ubuntu 17.04 can not resolve DNS servers with DNSSEC support as of 2017-04-18. Disable DNSSEC with this daemon:

sudo mkdir -p /etc/systemd/resolved.conf.d
printf "[Resolve]\nDNSSEC=no\n" | sudo tee /etc/systemd/resolved.conf.d/no-dnssec.conf

Reconfigure resolvconf if needed:

sudo dpkg-reconfigure resolvconf
# Say yes to "prepare /etc/resolve.conf for dynamic updates?"

And reboot.

  • I have already tried this and it has not changed anything. I had already used this solution for an earlier issue – Blue Dabba Dee Apr 22 '17 at 14:12
  • 1
    @BlueDabbaDee then please include that in the question next time ;-) – Rinzwind Apr 22 '17 at 14:12
  • @Rinzwind I will – Blue Dabba Dee Apr 22 '17 at 14:13
  • 1
    I am facing the opposite problem. After a update, the computer is getting connected to ethernet but internet browsing not working. On the same computer (16.04 LTS) the wifi is working flawlessly for everything. I am still searching for an answer here before posting a question. – bluepearlsky Jul 19 '17 at 14:32
  • I have Ubuntu 16.04 LTS and the second part about the resolvconf solved my problem. However, it seems all that was needed was to reconfigure resolvconf. Presence or absense of the new .conf file did not have any effect.. – dojuba Nov 14 '17 at 18:07

protected by Community Dec 10 '17 at 6:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.