0

I have issue on Ubuntu 17.04, Internet works fine and after a few minutes, sometimes hours suddenly it stops working. Also sometimes when I run the system in the morning, the internet is not working from the beginning.

In both cases I have message in chrome browse:

DNS_PROBE_FINISHED_BAD_CONFIG

Worth to add, I can ping ip adress. For e.g ping wp.pl - not working but ping 212.77.100.101 - working.

Also internet in this time working fine on other devices - android smartphone, desktop PC with OpenMandriva or even on the same device but on other OS - Fedora 25. So look like this is bug in Ubuntu 17.04, but I can't fix it. For Ubuntu 17.04 help me only restarting router...

I trying fix it like in this topic: DNS_PROBE_FINISHED_BAD_CONFIG error in Ubuntu 14.04

but any solution not working for me.

1
  • 1
    Please edit your question to add the result of the terminal command: dmesg | grep -i dns If the result is lenthy, post the output here and give us the link: paste.ubuntu.com – chili555 Apr 22 '17 at 13:04
0

I think this link may help you.

Summary:

sudo rm /etc/resolv.conf
sudo ln -s ../run/resolvconf/resolv.conf /etc/resolv.conf
sudo resolvconf -u

Then refresh your browser or others.

1
  • psst. dont forget cp /etc/resolv.conf ~/ so that resolv.conf is backed up – JSON Oct 15 '17 at 5:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.