I am trying to get wayland running using UbuntuGnome 17.04 with nvidia-381 installed using the graphics-drivers ppa and a Geforce 1050TI card. Using older Ubuntu versions I was able to select between Weston, Wayland and/or Kodi, if installed. Using 17.04 I may only choose between Gnome and Gnome Classic. I installed all packages needed, as far as i know, as well as their recommended packages, synaptic is showing. Is there any package I need to install or reinstall or reconfigure?

Using no nvidia drivers, the regular nouveau and xorg drivers or the xorg-edgers or oibaf ppa lets me run the system, but without having any hardware acceleration. As well as no option to choose wayland in GDM. I just may choose Kodi then...

The installed packages on my machine for using wayland are:

enter image description here

Thanks a lot.

Try this (highly experimental according to nVIDIA, but actually worked in my case)

sudo modprobe -r nvidia-drm 
sudo modprobe nvidia-drm modeset=1
  • Good to know. Do you also know how to revert that changes if set for a tryout? – starkus Jun 26 '17 at 17:12
  • sudo modprobe -r nvidia-drm – voodooattack Jun 27 '17 at 18:24

I tried a lot of workarounds but nvidia drivers don't support wayland session using gdm and gnome. The only way to get it running was to set modeset=1 with sudo gedit /etc/modprobe.d/nvidia-graphics-drivers.conf using nvidia-381. After sudo update-initramfs -u and rebooting I was able to log into wayland, but that workaround breaks something as I was not able to run anything as root or superuser. I hope there will be a fix soon. The only way to set it back is to switch to tty and using nano instead of gedit to set the entries to their defaults.

  • This worked for me! Wayland seems a little rough around the edges, a little slower than x at the moment but everything seems to work. – micwallace Apr 30 '17 at 8:02
  • 2
    Setting modeset=1 breaks the whole system for me: gnome session does not start. I have nvidia GTX 980 Ti, nvidia-381, Ubuntu 17.04 – artem Jun 7 '17 at 16:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.