1

I used Windows but uninstalled it, and installed Ubuntu 16.04. Now I have a big problem: My WiFi stopped working. I tried everything I could find, and still no WiFi. for 10 days.

My machine is :

  • Acer Aspire V13 / V3-371-55PF
  • CPU Intel Core i5-4210U 1.7 GHz with Turbo Boost ut to 2.7 GHz
  • Network controller: Qualcomm Atheros AR9462 Wireless Network Adaptor (rev 01)
  • Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)
  • Please edit your question to add the result of these terminal commands: sudo modprobe ath9k and also: rfkill list all – chili555 Apr 22 '17 at 13:08
  • 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: hci0: Bluetooth Soft blocked: yes Hard blocked: no 2: acer-wireless: Wireless LAN Soft blocked: no Hard blocked: no – Angel Trifonov Apr 22 '17 at 14:39
  • Was there no response at all to: sudo modprobe ath9k? Let's check for messages in the log: dmesg | grep ath – chili555 Apr 22 '17 at 14:42
  • sudo modprobe ath9k : no response – Angel Trifonov Apr 22 '17 at 14:50
  • dmesg | grep ath [ 11.890800] ath: phy0: ASPM enabled: 0x43 [ 11.890802] ath: EEPROM regdomain: 0x6a [ 11.890803] ath: EEPROM indicates we should expect a direct regpair map [ 11.890804] ath: Country alpha2 being used: 00 [ 11.890804] ath: Regpair used: 0x6a [ 12.138944] usbcore: registered new interface driver ath3k [ 13.451621] ath9k 0000:02:00.0 wlp2s0: renamed from wlan0 – Angel Trifonov Apr 22 '17 at 14:51
1

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

If these changes do not help, please try:

sudo modprobe -r ath9k
sudo modprobe ath9k nohwcrypt=1

If it helps, make it permanent:

sudo -i
echo "options ath9k nohwcrypt=1"  >>  /etc/modprobe.d/ath9k.conf
exit
  • I don't have permission to change router's configuration.But with this router works 4 other machines. Second - I work with my machine at home, at work and other places. Everywhere is same. Reg was 00, I changed it and set it up permanently my country code. Set Ipv6 to ignore. Set :- ath9k nohwcrypt=1 . WiFi still doesn't work. I'm sorry. – Angel Trifonov Apr 23 '17 at 6:35
  • The following answer doesn't help askubuntu.com/a/546970/498780 ? – GAD3R May 1 '17 at 18:21
  • 1
    @GAD3R The answer you linked is a suggestion to blacklist acer-wmi in order to correct a hard-block. In the readings Angel Trifonov gave us, there is no hard-block at all. – chili555 May 1 '17 at 20:02
0

I've got the same laptop running ubuntu gnome 16.04, the wifi would connect to my home network but be completely unusable. Within seconds of connecting I'd be getting 70-90% packet loss with pings in the 1000's ms, often dropping from that to timeouts and something like a buffer error.

The fix for me was disabling the 802.11'n' features on the card, the issue stopped straight away and the wifi hasn't had an issue for weeks now.

I believe this was the post I got it from, the iwlwifi part halfway down. How do I keep my Wifi from dropping out? - Ask Ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.