The Ubuntu 17.04 distribution is not connecting to Internet, not in a live USB session, nor after the install. I've got a Dell Inspiron 24-7459. This is a major issue as I cannot update or download anything. Without the possibility of connecting to the Internet I'm completely stuck.

I've followed the instructions on this thread and nothing changes:

Can't connect to wifi on Ubuntu 17.04

In my case it's not a question of WIFI only. The Internet is not working even under the wired connection.

  • so this answer didn't work for you? have you tried to kill Network manager? or a reboot? Apr 22, 2017 at 11:33
  • Welcome to AskUbuntu! Could you please run the network diagnostics and edit your question to include a link to the result? I know it may seem a bit overwhelming for a novice but your info so far is a bit vague and the diagnostics will likely cover all options that may cause your issue. Thanks. Apr 22, 2017 at 12:00
  • Thanks, Sumeet. Before my post I already tried with no success the solutions of the link you've send me. I've killed many times the Network manager and rebooted the systems. All the things I try give no result for the moment.
    – Xavier
    Apr 22, 2017 at 12:03
  • Sorry David, I should have not posted anything as I don't want to disturb or make anger anyone. It's very difficult for me to suit your requirements, as my computer has no connection and I'm trying to do want I can with another one. I don't understand fully what to do. Everybody here has lots more knowledge than me. I'm not even a English speaker. It's complicated. I just wanted to install Ubuntu. Give me a bit of time to read, understand and try to post the things the way you say. Thanks for helping.
    – Xavier
    Apr 22, 2017 at 12:10

2 Answers 2



Go to System settings/Network/Wired/Options and then choose the enp4s0 option. It worked for me.

  • How does that solve Wi-Fi issue?
    – iammilind
    Aug 3, 2017 at 7:04

I had the case where I could connect to WiFi but couldn't access webpages due to DNS-related errors. This resolved it for me:

Ubuntu 17.04 systemd-resolved DNS lookups randomly fail

Ubuntu 17.04 can not resolve DNS servers with DNSSEC support as of 2017-04-18. Disable DNSSEC with this daemon:

sudo mkdir -p /etc/systemd/resolved.conf.d printf "[Resolve]\nDNSSEC=no\n" | sudo tee /etc/systemd/resolved.conf.d/no-dnssec.conf

Optionally reconfigure resolvconf if you messed with it (say yes to "prepare /etc/resolve.conf for dynamic updates?"):

sudo dpkg-reconfigure resolvconf

Restart systemd-resolved:

sudo systemctl restart systemd-resolved

Your DNS should start working. You can check by trying systemd-resolve www.google.com and seeing a response.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.