I want to disable the touchpads on my laptops while typing. This used to be an option in the graphical system settings of Ubuntu but that option is gone in 16.04. I don't recall in which version I saw that option the last time.

These questions and their answers did not help:

This answer (of yet another question) did actually disable the touchpad (only tried it on one laptop) while I was typing. I then enabled clicking by tapping again (as described in that answer) which also worked ... kind of: When I moved by mouse pointer somewhere using my touchpad and then immediately tapped to click that element, the mouse pointer always jumped back a few millimeters into the direction I moved the mouse pointer from. This means that I always missed what I was intending to click at except when clicking on large elements or intentionally waiting a short moment before tapping (which pissed me off after about a minute).

touchpad-indicator actually disables the touchpad while typing. It does that for 2000 ms after the last key stroke by default which should probably be decreased a lot. The only weird side effect I noticed within the first minute is that it enables circular scroll by default but this can easily be disabled in the settings. So it's already better than all the other options. However, it has huge drawbacks:

  • When I type text in Emacs (probably the same for other text editors but I had to write a few pages of text right after I installed it and that that in Emacs), every few minutes, it the cursor randomly jumps up 2 to 8 lines which causes me to mess my text up and really pisses me off. Furthermore, the mouse pointer changes location (It vanishes while typing.) at the same time. This happened many, many times, and it definitely doesn't happen without touchpad-indicator, so it doesn't appear to be a bug in Ubuntu or Emacs, or a weird hardware malfunction of my keyboard.
  • After a few hours, the touchpad just stops working. Killing touchpad-indicator doesn't make it work again, launching it, again, doesn't, disabling the touchpad and re-enabling it in the system settings doesn't, and disabling it via the FN keys and re-enabling it, doesn't, either. A connected mouse still works. The touchpad works again after the system is rebooted. This happened 2 or 3 times before I purged touchpad-indicator from my system. My laptop didn't show this behavior before I installed touchpad-indicator and I've been using it for some time since I removed it and this problem is gone. So even though I only have 2 or 3 data points regarding this, I'm pretty sure it's touchpad-indicator's fault.

Is there a way to disable a laptop's touchpad while typing in Ubuntu 16.04 without weird side effects?


$ xinput
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech Gaming Mouse G502                id=11   [slave  pointer  (2)]
⎜   ↳ Logitech Gaming Mouse G502                id=12   [slave  pointer  (2)]
⎜   ↳     Touchpad                              id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ HD WebCam                                 id=14   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=15   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                          id=16   [slave  keyboard (3)]
  • I have the same problem, syndaemon can help somewhat but it's unstable and ends up not working or disables the touchpad. Have you found something? Three time i had to point back to this box, just for writing this. – mote May 1 '17 at 13:21
  • @mote No, I haven't found a solution. The main reason I wanted this is so that I don't interact with the touchpad while playing a game. I since discovered that laptops' FN keys typically provide the option to disable the touchpad. Funnily enough, on the day I was going to write a script to do this in software. I didn't already do it because I needed to decide whether to use a key binding or whether to automate it when launching the game I play (and in the latter case: Should I try to enable it again when the game is minimized?). But I didn't find a solution to the described problem. – UTF-8 May 1 '17 at 13:27
  • I forgot to mention 'touchpad-Indicator', it can also make the touchpad turn off when typing, along with other options. – mote May 2 '17 at 6:05
  • @mote Why doesn't it solve your problem? – UTF-8 May 2 '17 at 7:42
  • 'touchpad-Indicator' ? I'm not exactly sure it doesn’t. I just tried started using it for the second time after giving up on it the first time, were it seemed to stop working at times and other times possibly making the mouse cursor act strange. – mote May 2 '17 at 12:56

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.