I have a fresh install of 11.04 64bit, with 2 administrator accounts and 4 normal accounts. The 4 normal accounts (the kids' accounts) don't have passwords, they can login simply by clicking on their names.

When any of the users -- either admin or normal -- tries to switch to another account by clicking in the top-right corner of the screen and selecting another user, the screen goes black and the entire system locks up. Even CTRL+ALT+F1 through F7 does nothing. This is reproducible 100% of the time on this system.

I can ssh into the box when the console locks up, and by running top, I see that Xorg is consuming about 100% of the CPU. Looking at the output of "ps axfu" in bash while the system is in this "locked up" state, here is the lightdm and X process tree:

root      1153  0.0  0.1 183508  4292 ?        Ssl  Dec26   0:00 lightdm
root      2187  0.4  4.6 265976 164168 tty7    Ss+  00:43   0:21  \_ /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
stephane  2612  0.0  0.3 266400 10736 ?        Ssl  01:52   0:00  \_ /usr/bin/gnome-session --session=ubuntu
stephane  2650  0.0  0.0  12264   276 ?        Ss   01:52   0:00  |   \_ /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/bin/gnome-session --session=ubuntu
stephane  2703  0.8  3.0 562068 106548 ?       Sl   01:52   0:08  |   \_ compiz
stephane  2801  0.0  0.0   4264   584 ?        Ss   01:52   0:00  |   |   \_ /bin/sh -c /usr/bin/compiz-decorator
stephane  2802  0.0  0.3 265744 13772 ?        Sl   01:52   0:00  |   |       \_ /usr/bin/unity-window-decorator
root      3024 80.6  0.3 107928 13088 tty8     Rs+  01:53  12:34  \_ /usr/bin/X :1 -auth /var/run/lightdm/root/:1 -nolisten tcp vt8 -novtswitch

That last process, pid #3024 in this case, is what has the CPU pegged.

In case it matters (I suspect it might) here is what I think may be the relevant information for my video card, taken from /var/log/Xorg.0.log:

[  3392.653] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so
[  3392.653] (II) Module glx: vendor="FireGL - AMD Technologies Inc."
[  3392.653]    compiled for 6.9.0, module version = 1.0.0
[  3392.655] (II) LoadModule: "fglrx"
[  3392.655] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so
[  3392.672] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
[  3392.672]    compiled for, module version = 8.88.7
[  3392.672]    Module class: X.Org Video Driver
[  3392.759] (==) fglrx(0): ATI 2D Acceleration Architecture enabled
[  3392.759] (--) fglrx(0): Chipset: "AMD Radeon HD 6410D" (Chipset = 0x9644)

Lastly: I did see this posting: Change user on 11.10 hangs system ...but I checked, and the libpam-smbpass package isn't installed on this system.

  • Are you still looking for help or have you solved this problem? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! – coversnail Apr 15 '12 at 12:43
  • This is still a problem today. Never resolved. – Stéphane Apr 16 '12 at 6:36
  • Can you please include your /var/log/lightdm/lightdm.log file? You said you are able to ssh into the machine, so while the system is in limbo, ssh in and get the log file. – Anthony Oct 10 '12 at 16:03

When you log out -> the login screen settings are governed by the root user
(I think).
So any video settings relevant would be "different" (from the settings to your monitors and graphics as /user)

So if i were to take a stab in the dark, I would say general "Graphics error" (because i dont know enough information)

I recommend troubleshooting by logging in as "Ubuntu 2D" (As unity) or "Gnome Classic (no effects) if you have it installed, and then see if the 2D environment also crashes.

If they still crash, next successful logon change window managers via

sudo dpkg-reconfigure gdm

Pending you have Gnome manager installed.
Mind you: this is, of course, only what i would do to try to deduce the problem.

The only thing that makes sense to me, is that somehow it wont let go of the video or a device.

Other ideas include -> removing extra USB devices(Ive personally had weird frezes because of different USB devices, one time a webcam.

let me know...

| improve this answer | |

May I know the specifications of your computer?

  • Open "System Monitor"
  • Click on "System" tab
  • Under "Hardware", copy and paste "Memory" and "Processor" information

or, you could also attach a screen-shot of the "System Monitor"

I believe that your computer tends to hang because while "switching" accounts, your system gets overloaded. This usually happens to computers with low specifications. From the information already posted by you, it seems as though your computer does run on low specifications. (The video card "Chipset: "AMD Radeon HD 6410D" is known for low performance).

Next time, try logging out from one account before logging into another account. This way, your computer's resources will not be locked up by an account that is not being used.

I believe this method will avoid your system from freezing.

If you prefer to "switch" accounts rather than logging out and then logging in to another account, you need to upgrade your computer or buy a new one with higher specifications/performance.

| improve this answer | |
  • This shouldn't have been listed as an answer, but rather as a comment to the original question. – Anthony Oct 12 '12 at 3:19

Accounts with no password can be a particular problem for the locked account authorisation. I don't mean the LightDM login screen - that works fine with null passwords. The locked account authorisation comes into play if the account is locked by the screensaver or similar, or after the focus is switched away from the user as happens when switching accounts. It just doesn't know about null passwords or how to handle the situation.

I suggest changing the passwords on all the kid's accounts to something like 'abc' or similar, and retesting.

I'm not certain this is the problem mind you since the normal way it manifests is simply a complete inability to get back into the account once you switch away from it, but I certainly think it will make your life a lot easier if can give the locked account verification process something to work with.

| improve this answer | |

ALT-SysReq-k (or ALT-PrintScreen-k) which has taken the place of CTRL-ALT-BKSP to restart Xorg does not fix the situation. I always return to a blank screen.

do-release-upgrade from 11.10 to 12.10 greatly reduced the incidences of Xorg inescapable blank screens.

| improve this answer | |

I'm guessing here but are you on wireless with mounted shares. Logging out disconnects your wireless, and will hang linux. You can wait for it to time out (some times several minutes) .

Theres no real fix aside from manually unmounting first.

Also ATI cards have always been really picky about VTY switching. You could just be hitting that bug, though that wouldn't cause the system to hang, just to have a black screen that won't go away till you restart.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.