Update: I've decided to return the card as there doesn't seem to be any linux firmware support to date.

I can't get my Wifi card (ASUS_PCE-AC88) to work on Ubuntu 16.04 The card does not show up in the network manager.

I've created this question specifically because I haven't found any good information on ubuntu drivers for [14e4:43c3] yet. The thread on askubuntu about broadcom drivers (Installing Broadcom Wireless Drivers) does not list my version.

Please let me know if you need any more information.

I've already tried installing bcmwl-kernel-source and loading the module wl via sudo modprobe wl which resulted in an error on boot:

ERROR @wl_cfg80211_detach : NULL ndev->ieee80211ptr, unable to deref

I'm running the following kernel version: 4.4.0-72-generic

Info on the chip:

lspci -vnn | grep Network
02:00.0 Network controller [0280]: Broadcom Limited Device [14e4:43c3] 
(rev 04)

lshw -class network
*-network UNCLAIMED  
   Beschreibung: Network controller
   Produkt: Broadcom Limited
   Hersteller: Broadcom Limited
   Physische ID: 0
   Bus-Informationen: pci@0000:02:00.0
   Version: 04
   Breite: 64 bits
   Takt: 33MHz
   Fähigkeiten: pm msi pciexpress cap_list
   Konfiguration: latency=0
   Ressourcen: memory:feaf8000-feafffff memory:fe000000-fe7fffff 

More info on the card: https://wikidevi.com/wiki/ASUS_PCE-AC88


dmesg | grep brcm
[   13.868848] usbcore: registered new interface driver brcmfmac
[   14.001095] brcmfmac 0000:02:00.0: Direct firmware load for 
brcm/brcmfmac4366b-pcie.txt failed with error -2
[   16.403501] brcmf_pcie_download_fw_nvram: FW failed to initialize

Running sudo modprobe -r wl and sudo modprobe brcmfmac did not print anything to the console. (Wifi card is still UNCLAIMED and does not appear in network manager.)

Update 2

modinfo brcmfmac | grep firmware
firmware:       brcm/brcmfmac4354-sdio.txt
firmware:       brcm/brcmfmac4354-sdio.bin
firmware:       brcm/brcmfmac43455-sdio.txt
firmware:       brcm/brcmfmac43455-sdio.bin
firmware:       brcm/brcmfmac43430-sdio.txt
firmware:       brcm/brcmfmac43430-sdio.bin
firmware:       brcm/brcmfmac4339-sdio.txt
firmware:       brcm/brcmfmac4339-sdio.bin
firmware:       brcm/brcmfmac43362-sdio.txt
firmware:       brcm/brcmfmac43362-sdio.bin
firmware:       brcm/brcmfmac4335-sdio.txt
firmware:       brcm/brcmfmac4335-sdio.bin
firmware:       brcm/brcmfmac43340-sdio.txt
firmware:       brcm/brcmfmac43340-sdio.bin
firmware:       brcm/brcmfmac4334-sdio.txt
firmware:       brcm/brcmfmac4334-sdio.bin
firmware:       brcm/brcmfmac4330-sdio.txt
firmware:       brcm/brcmfmac4330-sdio.bin
firmware:       brcm/brcmfmac4329-sdio.txt
firmware:       brcm/brcmfmac4329-sdio.bin
firmware:       brcm/brcmfmac43241b5-sdio.txt
firmware:       brcm/brcmfmac43241b5-sdio.bin
firmware:       brcm/brcmfmac43241b4-sdio.txt
firmware:       brcm/brcmfmac43241b4-sdio.bin
firmware:       brcm/brcmfmac43241b0-sdio.txt
firmware:       brcm/brcmfmac43241b0-sdio.bin
firmware:       brcm/brcmfmac43143-sdio.txt
firmware:       brcm/brcmfmac43143-sdio.bin
firmware:       brcm/brcmfmac43569.bin
firmware:       brcm/brcmfmac43242a.bin
firmware:       brcm/brcmfmac43236b.bin
firmware:       brcm/brcmfmac43143.bin
firmware:       brcm/brcmfmac4371-pcie.txt
firmware:       brcm/brcmfmac4371-pcie.bin
firmware:       brcm/brcmfmac4366b-pcie.txt    
firmware:       brcm/brcmfmac4366b-pcie.bin
firmware:       brcm/brcmfmac4365b-pcie.txt
firmware:       brcm/brcmfmac4365b-pcie.bin
firmware:       brcm/brcmfmac4358-pcie.txt
firmware:       brcm/brcmfmac4358-pcie.bin
firmware:       brcm/brcmfmac43570-pcie.txt
firmware:       brcm/brcmfmac43570-pcie.bin
firmware:       brcm/brcmfmac4356-pcie.txt
firmware:       brcm/brcmfmac4356-pcie.bin
firmware:       brcm/brcmfmac4350-pcie.txt
firmware:       brcm/brcmfmac4350-pcie.bin
firmware:       brcm/brcmfmac43602-pcie.txt
firmware:       brcm/brcmfmac43602-pcie.bin
parm:           fcmode:mode of firmware signalled flow control (int)
  • 1
    Please open a terminal and do: sudo modprobe -r wl and next: sudo modprobe brcmfmac Finally, let's gather some diagnostics: dmesg | grep brcm Please edit your question to add the result of the final command. – chili555 Apr 21 '17 at 19:47
  • @chili555 Thank you. I've updated the question as requested. – pbz Apr 21 '17 at 19:53
  • @pbz Hi can you please test to see if the Special Case in askubuntu.com/questions/55868/… will also help you. I just tested 2 ASUS PCE-AC88 AC3100 and it is working correctly. One on 17.04 and another in 17.10. Let me know friend. – Luis Alvarado Aug 19 '17 at 2:07

I know this is an old thread but support for this card is now in the latest version of Ubuntu.

I just installed Ubuntu server 19.04 and the card worked out of the box.

Beware it did not work at all with the new installer which crashes on boot and I could not get to work, so use the alternative installer instead.


As you can see from the Wikidevi page that you linked, the correct driver for your device is brcmfmac; not the proprietary driver wl provided by bcmwl-kernel-source. In dmesg, it shows that the driver loaded but the required firmware wasn't found.

I believe that the latest version of linux-firmware has the needed file. With a working internet connection by ethernet, tether or whatever means possible, please open a terminal and do:

wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.164_all.deb
sudo dpkg -i linux-firmware*.deb

Reboot and let us see:

dmesg | grep brcm 
  • I've installed the package and rebooted. dmesg | grep brcm still has the same output as before. – pbz Apr 21 '17 at 20:23
  • Please edit your question to add the result of: modinfo brcmfmac | grep firmware My version of the driver doesn't call for any txt files; only bin. – chili555 Apr 21 '17 at 20:38
  • May we also see the result of: sudo mount -t efivarfs none /sys/firmware/efi/efivarsAnd then: ls /sys/firmware/efi/efivars – chili555 Apr 21 '17 at 21:12
  • sudo mount -t efivarfs none /sys/firmware/efi/efivars mount: mount point /sys/firmware/efi/efivars does not exist – pbz Apr 21 '17 at 21:15
  • How about the second command? – chili555 Apr 21 '17 at 21:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.