I have upgraded from 16.10 to 17.04 and now I am not able to connect to any WiFi Hotspots that I create.

Anytime I click on the connect button, it says Configuring but does not connect. At times it tries to connect and soon after deactivates the connection.


2 Answers 2


I installed dnsmasq and it works.

  • 2
    Welcome to the site and thank you for your input. Please edit your answer to provide a bit more information such as the sud code to install dnsmasq, if it worked for you and the expected result. All this will help the users resolve their issue.
    – Phil UK
    Apr 25, 2017 at 0:34
  • This worked for me. Thanks. One suggestion though, I know my way aroung Linux (Ubuntu) so I understand your statement but as was suggested above, maybe you can leave some instructions to be followed for the not so experienced users. Apr 26, 2017 at 0:55

All you need to do is Open a terminal by pressing Ctrl + Alt + T and run:

sudo -H gedit /etc/NetworkManager/NetworkManager.conf

(On Ubuntu Mate it should be pluma instead of gedit; use kate on Kubuntu, leafpad on Lubuntu and mousepad on Xubuntu)

At the bottom of this file, copy and paste the following:


Your final results should look something like this: Configuration file to allow USB Wifi to work in Ubuntu 17.04

Then just save and close the file and run:

sudo service network-manager restart

And wifi should work again!


Not the answer you're looking for? Browse other questions tagged or ask your own question.