0

Today I tried executed the command: apt-get update. But there seems to be a problem, because I get error-messages like these:

Err https://mirror.umd.edu trusty/main Sources
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

Err https://mirror.umd.edu trusty/restricted Sources
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

etc. And then:

W: Failed to fetch https://mirror.umd.edu/ubuntu/dists/trusty/main/source/Sources  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

W: Failed to fetch https://mirror.umd.edu/ubuntu/dists/trusty/restricted/source/Sources  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

etc.

I guess this problem is because I don't have a file called 'ca-certificates.crt' in that folder. I looked also on another server with Ubuntu 14.04 on it, but this certicate file doesn't excist there either. So, where can I find/download this crt-file?

I hope someone can help me.

Thanks, Kevin

2

Their certificate is invalid as of the other day - they forgot to renew their SSL Certificate

Simply visiting the URL with Firefox and checking the certificate warning shows you this.

mirror.umd.edu uses an invalid security certificate.

The certificate expired on 19/04/17 13:00.

The current time is 21/04/17 14:31.

You can either

  • wait a bit
  • Change repository
  • Change the URLs in your apt sources to http:// (safe enough fi GPG signing is performed)
  • Set Verify-Peer in your apt.conf settings to false (not recommended as a set-and-forget solution)
  • Thanks for your reply. For this moment I did choose the 3rd option you gave. However, if they don't gonna update their security-certificate, I want to change the repository. But therefore I have to look for a list with https://-repository's. But, for now, I wait a bit. – kevinx Apr 23 '17 at 14:41
  • In good news - they updated it as of today, so you can turn off that setting now. – taifwa Apr 24 '17 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.