0

Well,, I was trying to do a dual boot installation of Windows/Ubuntu. Somewhere I somehow messed up. ( I was constantly formating, partitioning and booting my external 500GB HDD), and now it will not mount on neither Ubutnu nor Windows.

My best guess is that I messed up something while using GParted, or while creating a bootable drive. Though I can still see it in GParted, but for some reason it now shows that it has 1,82 TiB?

enter image description here

I tried to delete the unknown Partition, but it did not work, plus I get some strange warning

enter image description here

I used different commands in terminal in order to see what was going on,This is what I got.NOTE:( My laptop has single internal 128GB SSD and 1TB internal HDD.)

enter image description here

And for fdisk -l enter image description here

I found somebody on this forum with similar problem on their USB,here but it does not say how were they able to format it and return it to usable form.

EDIT: Ok,, so I tried using some terminal commands Katu proposed and it sort of worked. This You-Tube tutorial was helpful

First I wrote:

$ sudo fdisk /dev/sdb

This way I was able to enter the hard drive. Then I wrote in

Command (m for help): d
(Note: d= delete)

Command (m for help): w
(Note: w= write)

I went out (exited) of the Terminal and entered GParted... And FINALLY that "unknown" Partition was deleted,, and my Hard drive was showing the right size.. as you can see on the screen-shot below enter image description here

Then I just used GParted to create a new Partition. enter image description here

Only problem is that now it is a read-only HDD, but I bypass that by using $ sudo nautilus

  • 1
    Have you tried formatting the drive from the command line with fdisk and mkfs? askubuntu.com/questions/86890/… – Katu Apr 21 '17 at 11:57
  • 1
    If not running Windows you should be using gpt. And with NVMe drive you must make sure you use very new partitioning tools that have correct partition alignment. ibm.com/developerworks/linux/library/… But extended partitions are not directly written into and first sector then does not have to be aligned, only logical partitions inside. Sometimes gdisk works, if you do not want conversion to gpt, just do not write partitions use q to exit. rodsbooks.com/gdisk/walkthrough.html Post this: sudo gdisk -l /dev/sdb – oldfred Apr 21 '17 at 13:51
  • Well thanks guys,, you both helped me quite much – Sky_ Apr 21 '17 at 15:15
0

In regards to fixing the partition size issue, this has happened to me when using different tools to create the ISO on a flash drive. To fix it I normally do the following (assuming the flash drive is /dev/sdd)

sudo dd if=/dev/zero of=/dev/sdd bs=2048 count=32

This is assuming that the error of having a Physical block size of 2048 but Linux reporting 512 shows up like in your case and mine. I do this because sometimes doing fdisk (or cfdisk, gdisk, etc..) fails when trying to delete the partition or simply does not save it.

enter image description here

After doing this, I can safely go to gparted again and partition (After creating the partition table and then formatting with any type of format. If the partitions are not working as you mentioned, I would advice doing a chmod on it which most of the time works. Simply do the following:

sudo chmod 777 /media/USERNAME/flashDriveName -R

for example:

sudo chmod 777 /media/cyrex/E829-2912 -R

To test, just try to create a folder inside the external device or a file. Everything should be working up to this point. On specific cases you need to disconnect the device and connect it back again.

Just in case, the key icon on gparted means that the partition is mounted. You would need to unmount it before doing anything with it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.