1

Problem: Moving windows, accessing the Activities overlay etc. is jerky and not smooth.

I'm running Ubuntu Gnome (hey, soon I'll just be able to say Ubuntu!) on 17.04. My hardware is a 4k screen with Intel® HD Graphics 530 (Skylake GT2) running on i7-6700HQ CPU @ 2.60GHz × 8 with 16GB RAM.

I don't think it should be jerky.

What I've tried

I've tried uninstalling xserver-xorg-video-intel, as recommended on a redit post (which refers to a note on a Debian package saying it's deprecated), although I could not find the xorg.conf.d/20-intel.conf referred to in that post. There was no noticeable difference.

I've tried running the Wayland session. (click your name in the gdm log in screen, use the cog icon to select Gnome on Wayland, then enter your password). If anything this is worse, although I have no way to measure this except my eyes.

  • Thanks, might try that although it doesn't list 17.04 as supported – artfulrobot Apr 21 '17 at 6:38
0

I had the same issue till this morning. Ubuntu GNOME 17.04 is running Gnome 3.24, and this issue seem to affect every Gnome 3.2x versions.

I've tried uninstalling xserver-xorg-video-intel, as recommended on a redit post (which refers to a note on a Debian package saying it's deprecated), although I could not find the xorg.conf.d/20-intel.conf referred to in that post. There was no noticeable difference.

I saw the same "solution" on internet, that it seemed the only one around because distros with Gnome 3.20 or higher are not so much today.

I solved this opening "Software & Updates" (installed by default), went to the tab "Additional Drivers" and put the "Do not use this device" (before it was set on Intel-microcode), as in the screenshot:

Change to "Do not use this device", instead of intel-microcode

Restart shouldn't be needed, but I did it anyway and I suggest you to do the same. Just that solved the issue for me.

After that I've also tried to change the GPU's driver, and saw little differences between them, but this is very hardware-related, I think. So try to tweak it and see what is more performing on your machine.

| improve this answer | |
  • deactivating intel-microcode did not change anything for me – grg rsr Jan 25 '18 at 14:00
  • I don't have any additional drivers installed there (using Intel's on chip graphics), so nothing to disable... – smido Jun 26 '19 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.