1

Similar/maybe the same error at dpkg: error processing package libc-bin (--configure).

Although my example below is for sudo apt-get install, note that it also happens for the commands

  • sudo apt-get -f install
  • sudo apt-get upgrade
  • sudo apt-get autoremove
  • sudo dpkg --configure -a
  • and maybe a few other more

I am working with the Ubuntu 16.04 with ARM 64-bit architecture (on Jetson TX2 board). Help on resolving the segmentation fault would be very much appreciated. Since I cannot even install new software (due to this issue), help on ignoring the upgrades would also be appreciated. I am quite unfamiliar with linux, so please do try to answer accordingly. Thanks.

sudo apt-get install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up libc-bin (2.23-0ubuntu7) ...
Segmentation fault (core dumped)
/sbin/ldconfig.real: Path `/usr/lib/aarch64-linux-gnu/tegra' given more than once
/sbin/ldconfig.real: Path `/lib/aarch64-linux-gnu' given more than once
/sbin/ldconfig.real: Path `/usr/lib/aarch64-linux-gnu' given more than once
/lib/aarch64-linux-gnu:
        libssl.so.1.0.0 -> libssl.so.1.0.0
        libapparmor.so.1 -> libapparmor.so.1.4.0
        libiw.so.30 -> libiw.so.30
        liblvm2app.so.2.2 -> liblvm2app.so.2.2
        libcryptsetup.so.4 -> libcryptsetup.so.4.6.0
        libnss_mdns4.so.2 -> libnss_mdns4.so.2
        libusb-1.0.so.0 -> libusb-1.0.so.0.1.0
        libnss_files.so.2 -> libnss_files-2.23.so
        libhistory.so.6 -> libhistory.so.6.3
        libbrlapi.so.0.6 -> libbrlapi.so.0.6.4
        libatasmart.so.4 -> libatasmart.so.4.0.5
        libBrokenLocale.so.1 -> libBrokenLocale-2.23.so
        libdevmapper.so.1.02.1 -> libdevmapper.so.1.02.1
        libsystemd.so.0 -> libsystemd.so.0.14.0
        libcrypto.so.1.0.0 -> libcrypto.so.1.0.0
        libxtables.so.11 -> libxtables.so.11.0.0
        libwrap.so.0 -> libwrap.so.0.7.6
        libnih.so.1 -> libnih.so.1.0.0
        libnss_mdns6_minimal.so.2 -> libnss_mdns6_minimal.so.2
        libiptc.so.0 -> libiptc.so.0.0.0
        libisc-export.so.160 -> libisc-export.so.160.0.0
        libprocps.so.4 -> libprocps.so.4.0.0
        libaudit.so.1 -> libaudit.so.1.0.0
        libpam_misc.so.0 -> libpam_misc.so.0.82.0
        libnss_mdns.so.2 -> libnss_mdns.so.2
        libpci.so.3 -> libpci.so.3.3.1
        libgcc_s.so.1 -> libgcc_s.so.1
        libgcrypt.so.20 -> libgcrypt.so.20.0.5
        libpcsclite.so.1 -> libpcsclite.so.1.0.0
        liblzo2.so.2 -> liblzo2.so.2.0.0
        libnss_hesiod.so.2 -> libnss_hesiod-2.23.so
        libusb-0.1.so.4 -> libusb-0.1.so.4.4.4
        libseccomp.so.2 -> libseccomp.so.2.2.3
        libreadline.so.6 -> libreadline.so.6.3
        liblzma.so.5 -> liblzma.so.5.0.0
        libnewt.so.0.52 -> libnewt.so.0.52.18
        libacl.so.1 -> libacl.so.1.1.0
        libss.so.2 -> libss.so.2.0
        libpopt.so.0 -> libpopt.so.0.0.0
        libudev.so.1 -> libudev.so.1.6.4
        libdns-export.so.162 -> libdns-export.so.162.1.3
        libmemusage.so -> libmemusage.so
        libpcprofile.so -> libpcprofile.so
        libthread_db.so.1 -> libthread_db-1.0.so
        librt.so.1 -> librt-2.23.so
        libpthread.so.0 -> libpthread-2.23.so
        libreadline.so.5 -> libreadline.so.5.2
        libcrypt.so.1 -> libcrypt-2.23.so
        libncurses.so.5 -> libncurses.so.5.9
        libkeyutils.so.1 -> libkeyutils.so.1.5
        libz.so.1 -> libz.so.1.2.8
        libexpat.so.1 -> libexpat.so.1.6.0
        libply-splash-graphics.so.4 -> libply-splash-graphics.so.4.0.0
        libnss_nis.so.2 -> libnss_nis-2.23.so
        libparted.so.2 -> libparted.so.2.0.1
        libnss_nisplus.so.2 -> libnss_nisplus-2.23.so
        libnih-dbus.so.1 -> libnih-dbus.so.1.0.0
        libcidn.so.1 -> libcidn-2.23.so
        libnss_mdns4_minimal.so.2 -> libnss_mdns4_minimal.so.2
        libply-splash-core.so.4 -> libply-splash-core.so.4.0.0
        libjson-c.so.2 -> libjson-c.so.2.0.0
        libsepol.so.1 -> libsepol.so.1
/sbin/ldconfig.real: /lib/aarch64-linux-gnu/ld-2.23.so is the dynamic linker, ignoring

        ld-linux-aarch64.so.1 -> ld-2.23.so
        libslang.so.2 -> libslang.so.2.3.0
        libkmod.so.2 -> libkmod.so.2.3.0
        libhistory.so.5 -> libhistory.so.5.2
        libfdisk.so.1 -> libfdisk.so.1.1.0
        libply-boot-client.so.4 -> libply-boot-client.so.4.0.0
        libm.so.6 -> libm-2.23.so
        libselinux.so.1 -> libselinux.so.1
        libpamc.so.0 -> libpamc.so.0.82.1
        libglib-2.0.so.0 -> libglib-2.0.so.0.4800.2
        libatm.so.1 -> libatm.so.1.0.0
        libnl-3.so.200 -> libnl-3.so.200.22.0
        libparted-fs-resize.so.0 -> libparted-fs-resize.so.0.0.1
        libsmartcols.so.1 -> libsmartcols.so.1.1.0
        libip4tc.so.0 -> libip4tc.so.0.1.0
        libmount.so.1 -> libmount.so.1.1.0
        libntfs-3g.so.861 -> libntfs-3g.so.861.0.0
        libcgmanager.so.0 -> libcgmanager.so.0.0.0
        libtinfo.so.5 -> libtinfo.so.5.9
        libmnl.so.0 -> libmnl.so.0.1.0
        liblvm2cmd.so.2.02 -> liblvm2cmd.so.2.02
        libresolv.so.2 -> libresolv-2.23.so
        libpng12.so.0 -> libpng12.so.0.54.0
        libdl.so.2 -> libdl-2.23.so
        libply.so.4 -> libply.so.4.0.0
        libgpg-error.so.0 -> libgpg-error.so.0.17.0
        libanl.so.1 -> libanl-2.23.so
        libcap.so.2 -> libcap.so.2.24
        libpcre.so.3 -> libpcre.so.3.13.2
        libnss_compat.so.2 -> libnss_compat-2.23.so
        libattr.so.1 -> libattr.so.1.1.0
        libnss_dns.so.2 -> libnss_dns-2.23.so
        libtirpc.so.1 -> libtirpc.so.1.0.10
        libdevmapper-event-lvm2.so.2.02 -> libdevmapper-event-lvm2.so.2.02
        libfuse.so.2 -> libfuse.so.2.9.4
        libncursesw.so.5 -> libncursesw.so.5.9
        libnss_mdns_minimal.so.2 -> libnss_mdns_minimal.so.2
        libdevmapper-event.so.1.02.1 -> libdevmapper-event.so.1.02.1
        libc.so.6 -> libc-2.23.so
        libdbus-1.so.3 -> libdbus-1.so.3.14.6
        libutil.so.1 -> libutil-2.23.so
        libnss_mdns6.so.2 -> libnss_mdns6.so.2
        libcom_err.so.2 -> libcom_err.so.2.1
        libuuid.so.1 -> libuuid.so.1.3.0
        libbz2.so.1.0 -> libbz2.so.1.0.4
        libulockmgr.so.1 -> libulockmgr.so.1.0.1
        libe2p.so.2 -> libe2p.so.2.3
        libnsl.so.1 -> libnsl-2.23.so
        libpam.so.0 -> libpam.so.0.83.1
        libip6tc.so.0 -> libip6tc.so.0.1.0
        libbsd.so.0 -> libbsd.so.0.8.2
        libnl-genl-3.so.200 -> libnl-genl-3.so.200.22.0
        libblkid.so.1 -> libblkid.so.1.1.0
        libSegFault.so -> libSegFault.so
        libext2fs.so.2 -> libext2fs.so.2.4
/usr/lib/aarch64-linux-gnu:
Segmentation fault (core dumped)
dpkg: error processing package libc-bin (--configure):
 subprocess installed post-installation script returned error exit status 139
Errors were encountered while processing:
 libc-bin
E: Sub-process /usr/bin/dpkg returned an error code (1)
1

I don't think it would have been easy for anyone to figure this one out.

I was trying to install cudnn onto the Jetson without JetPack flashing. I used the information found at How can I install CuDNN on Ubuntu 16.04?.

Unfortunately the symbolic links maintained must have caused some trouble (as we can probably tell from the ldconfig having problems). I have since removed those copied files as well as the original. This resolves the segmentation fault.

edit:

In response to the comment below, I'll provide example commands I made. Do keep in mind, though, that my problem is somewhat specific to me. I happened to copy over files to certain directories while maintaining the symbolic links (via cp -P). So it's unlikely those example commands will help you. Though regardless, I suspect it has to do with the symbolic links being messed up somewhere.

$ rm /usr/include/cudnn.h
$ rm /usr/lib/x86_64-linux-gnu/libcudnn*
  • How di you solve he issue? – Andrea Baccega Apr 27 '17 at 8:16
  • When trying to install CuDNN, I made copies of files while keeping the symbolic links. This broke the ldconfig, so I fixed it by deleting the files. I'll edit with more precise commands. – Denis Li Apr 27 '17 at 11:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.