0

I have a Ryzen 1700X CPU paired with an Nvidia GTX 970 and was running the 4.10.9 mainline kernel on Kubuntu 16.10 flawlessly before I upgraded to Kubuntu 17.04. After upgrading, I found that my system would freeze (no ability to switch to tty1 via Ctrl+Alt+F1, system clock frozen, etc.) after a few hours of sitting idle. Thinking this was likely an issue with the kernel (although I was still running the 4.10.9 kernel at this point) I tried both upgrading to the 4.11 RC7 and downgrading the kernel included with 17.04 (4.10.0-19-generic) only to run into some very weird issues:

  • Initially, the graphics driver (nvidia-375) would fail to load, launching me into a KDE session at very low resolution where the bottom task bar did not appear
  • To fix this, I readded the ppa:graphics-drivers/ppa PPA (disabled in the upgrade) and tried:
    • Purging the old driver and reinstalling the same version
    • Purging, rebooting with nouveau with nomodeset and reinstalling
    • Upgrading to nvidia-381 which finally seemed to (partially) work.

The problems I am having now are quite strange:

  • The system has no animations whatsoever (e.g. maximize, minimize, open app launcher, shutdown/logout/reboot confirm)
  • Non-100% opacity does not work (e.g. the shutdown/logout/reboot confirmation has a pure gray background with no way to see what's behind it, can't change opacity of windows like I could previously)
  • Resizing by dragging a window to an edge shows a white outline (with no animation) instead of a ~50% opacity gray rectangle of how the resized window will look
  • Moving certain windows around rapidly (especially when Chrome is open) produces artifacting similar to this Windows XP example that disappears when I stop moving the window
  • Black pixels fill the parts of the windows' rounded corners that would normally be transparent making every window have square corners

I'm thinking this must have something to do either with my X server, the Nvidia driver, the kernel, or all of them but my searches of this site and others have turned up nothing relevant. Any help would be greatly appreciated!

0

I honestly can't believe the solution was this simple but I managed to solve this by going into System Settings -> Display and Monitor -> Compositor and changing the Rendering backend to XRender and the Scale method to Smooth (slower) rather than Crisp.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.