9

Hy folks

I'm a long time MacOS user and i just switched to GNU/Linux. My X1 Carbon arrived one week ago. Config: i7-7600, 16GB, 512GB. I know how to use a Terminal, i also know some CLI commands. But as it is for now - i don't know much about Linux internals.

Ubuntu Gnome 17.04 is my Distro of choice. I did try a few other Distros (Ubuntu Unity, openSUSE w. KDE, Xubuntu, Linux Mint). I feel most comfortable with Ubuntu Gnome.

The installation went without problems and everything seems to work well. I have three partitions (/boot/efi, / and /home). WiFi, Keyboard and Keyboard-light, Bluetoth are working out of the box. Battery life is awesome, > 10 hours with browser, writing and some youtube.

The only problem is suspend to ram. It's not working. On my macs i always used to close the lid (monitor) when i was not using them. Power management on Macs is really stable. I could pick up my machine, open the lid and after a few seconds continue to work exactly where i stopped. I hope there is a way to configure my Thinkpad to behave this way. When i close the lid now, it suspends (screen turns black, keyboard light turns of, i get a blinking red little dot on Thinkpad logo on the front of Monitor). When i open the lid everything freezes. Screen stays black, keyboard is not working. I have to hard reset / power off the machine.

How do i fix this? Are there any X1 Carbon users here which get this working?

Thanks in advance, i appreciate any help.

Update, 21.04.2017

I got a suggestion to try a live usb Ubuntu 16.04 iso. I tried and resume on suspend works. Then i tried Ubuntu 17.04 and Ubuntu Gnome 17.04 - and here also resume on suspend works out of the box. When i boot normal, do some stuff, close the lid the system suspends (blinking light shows that). When i open the lid, system is frozen - screen is black and keyboard is unresponsive.

My config:

  • Thinkpad X1 Carbon 5th. Gen (2017)
    • Kernel: 4.10.0-19-generic
    • CPU: Intel i7-7600U @ 2.8GHz
    • Memory: 2x8GB LPDDR3 SK Hynix
    • BIOS: 1.16
    • VGA: Intel HD 620 (using driver = i915)
    • SSD: NVME Samsung SM961/PM961
    • WiFi: Intel 8265/8275
    • Audio: Intel (using driver = snd_hda_intel)

Any help would be appreciated.

0

Could be related to a new power safe feature. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1678184

So far I'm running ok with the suggested workaround that prevents deeper power safe states. I modified /etc/default/grub the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nvme_core.default_ps_max_latency_us=6000 " and then make it active with "sudo update-grub " Se also accepted answer here: EXT4-fs error after Ubuntu 17.04 upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.