24

I just installed Ubuntu 17.04 on my Asus ROG GL752VW laptop and I decided to install gnome-shell and then install ubuntu-gnome-desktop.

After some use, I noticed a delay when using Fn + F5or F6 as media controls.

The first time I push these key combination Gnome hangs for a short time, and the next Fn + F-key pushes work without any delay until you push any other key-combination, like Alt + Tab which does not use the Fn key. I think it could be an ACPI related issue.

Update:

Each time gnome hangs there is a short peak of CPU usage and this is logged.

gnome-shell[10821]: pushModal: invocation of begin_modal failed
gnome-shell[10821]: pushModal: invocation of begin_modal failed
/usr/lib/gdm3/gdm-x-session[10635]: (II) NVIDIA(0):     cd/play CDPLAY 00000080 00000000 K
/usr/lib/gdm3/gdm-x-session[10635]: (II) NVIDIA(0): ACPI: received event:  PNP0C14:01 000000ff 00000000
/usr/lib/gdm3/gdm-x-session[10635]: (II) NVIDIA(0):     cd/play CDPLAY 00000080 00000000 K
/usr/lib/gdm3/gdm-x-session[10635]: (II) NVIDIA(0): ACPI: received event:  PNP0C14:01 000000ff 00000000

I tried reinstalling ubuntu-gnome-desktop but it didn't work.

Update:

I found this post which may be related.

I started getting sporadic freezes on my T460s. These freezes tended to occasionally manifest when pressing Mod4, or other modifier or media keys.

...This hinted to me that this issue might be a race condition in some process that talks to systemd-logind.

Update:

I started to think it is not an ACPI related problem, as I just installed the media keys gnome plugin and when I try to use it happens the same thing as if I were using Fn keys, the problem must be with gnome.

Update:

I just reinstalled ubuntu Gnome, and it does not happens on wayland so it is xorg related. Looking for a way to make gnome-wayland work with Nvidia drivers.

Update:

I just installed budgie-desktop and the problem is still happening.

Update:

Same problem happening in ubuntu 17.10 after some use. It's so annoying...

Update:

Problem still happening in ubuntu 18.04. Even worse some times the system crashes when using media keys.

7
20

For some reason my Gnome freezes when using Fn keys, or when I try to use 2 keyboards. A friend of mine pointed to me that it occurs when switching to a keyboard layout that has Scroll Lock enabled, so I disabled it in the X11 keyboard layout file for my language and it solved the problem.

The steps I followed are:

  1. Opened the keyboard layout file for my language, in my case:
    sudo nano /usr/share/X11/xkb/symbols/br
  2. Commented the line:
    modifier_map Mod3 { Scroll_Lock };
  3. Logged out and logged in again or run command setxkbmap.

These steps are specific for the Brazilian Portuguese ABNT2 Layout and may not work for other layouts, but it can help you find a similar solution.

8
  • 3
    Thank you very much, actually I have en(us), br and es keyboards enabled, I did it in br only and the delay is gone. – Jose Valencia Sep 5 '18 at 2:58
  • 4
    I signed up just to thank you. I spent some time trying to figure out what the heck was causing this delay in the hotkeys until I found your solution here. – user1091856 Sep 24 '18 at 22:03
  • 2
    Thanks man! This works! – Matheus Castello Mar 28 '20 at 4:34
  • 4
    Thanks a lot! You can apply the changes without logging out with setxkbmap -layout br – GuiGS May 5 '20 at 9:39
  • 2
    Someone give this guy a medal. – AFMeirelles Jul 13 '20 at 19:46
2

I had the same problem, but instead of Fn keys my problem was with the Ctrl key. Whenever I pressed Ctrl, gnome-shell CPU usage spiked!

So I figured out that my keyboard layout was set to en-GB, United Kingdom while my keyboard layout is en-US!

While the difference between the two layouts is minimal, it still somehow bugged the whole gnome-shell. So if anyone having the same problem, double check your keyboard layout from Gnome Settings!

1

I have reported the bug here: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1895486

I think if more people comment there, the Canonical will help us to fix the problem.

This bug appears on Ubuntu 20.04 too.

I opened a merge request in: https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config/-/merge_requests/112

Not the answer you're looking for? Browse other questions tagged or ask your own question.