2

When automounting an exFat USB, how do I define directory permissions and mount options?

I have a system (ubuntu 14.04.5) that is shared between multiple users, but only one (UID=1000) can attach USB's to the system.

All users share the same group (GID=1000).

When user 1000 copies files from vfat to a shared ext4 disk it copies the file with the same permissions in the vfat usb (0644), but when copying from the exfat usb, the permissions are (0700) so after a copy is made only UID=1000 can access the files in the shared disk.

I've been trying to change mount options without luck udisk2 does not let do that or if there is a way, it's unknown to me.

How can I ask gfvs->udisks2 to mount exfat partitions with umask=0770 ? udisks2 creates a mount point before mounting, but I can not change the permissions udisks2 sets on such mount point, again 0700.

Does anyone know how to customice a little the mount directory and mount process so I can share content copied from the exfat usb ?

I've tryed to change udev rules (80-udisks2.rules) with ENV{ID_FS_TYPE}=="vfat|ntfs|exfat|fuseblk", ENV{mount_options}="$env{mount_options},utf8,umask=000,allow_other" without any luck, and I don't want to hard code this options on udisks2 sources.

Any help is appreciated. Thanks all

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.