I'm curious what could be the reason why my installed version of Ubuntu requires acpi=off to launch while my Ubuntu live CD doesn't.

I'd add that:

1) I use an Acer Swift 3 Laptop.

2) After booting with acpi=off, I can't know the battery rate but I can still set the backlight power using /sys/backlight/intel_backlight files.

3) I have a dual boot Windows 10 along Ubuntu. I had to add Grub to the secure boot options to be able to boot to Ubuntu. I couldn't boot by just disabling the secure boot. I can still boot grub after disabling the secure boot.

4) I cannot use hwclock, the command just hang for about 10 seconds before failing with error code 74.

5) Installed Ubuntu fails to shutdown properly: It freezes on the Ubuntu loading screen. This may be due to hwclock (see this forum thread).

6) Sometimes I get no wireless connection and have to restart the laptop. No wireless network appears eventhough nmcli g tells me that wireless is enabled. It may be a consequence of force-powering it off too quickly at the previous shutdown. -- Using sudo service network-manager restart restores the wifi connection when the problem occurs.

7) I cannot use the touchpad with installed Ubuntu, eventhough I disabled the Touchpad Advanced Mode in the Bios. (It is mentioned that this mode requires special drivers). Disabling it prevents Windows (10) from detecting multiple fingers movements.

I use Ubuntu xenial 16.04.2 LTS, with kernel 4.8.0-46-generic

  • 1
    Maybe a different option which interacts with acpi? Compare the output of cat /proc/cmdline on the live system and on the installed system. Commented Jul 21, 2017 at 22:45

1 Answer 1


Hoo boy. I am copy pasting my answer from here -> Ubuntu 16.10 Acer Swift-3 multiple problems

The answer is simple, but first a little bit of backstory.

I too, own one of these machines, and I was famished when I found that Ubuntu would hang and would boot 1/10 percent of the time.

The reason is the following. The Acer Swift 3 firmware and the ACPI firmware in Linux 4.11 & below have a bit of a conflict...

But the solution is this! Linux kernel Devs fixed it in Kernel 4.12 and above! Ubuntu 17.10 officially comes with the latest kernel, but it will release after a few months.

so a TEMPORARY solution (not recommended by me, see below why) is to boot an Ubuntu ISO with the Mainline / unstable 4.12 or above kernel, or boot Ubuntu with acpi=off, use a separate mouse and keyboard, install the Mainline Kernels, and remove that acpi=off from the grub boot commands.

Why is this not a good solution? because Mainline kernels have many bugs and stuff, and I got harsh karma from using Mainline kernels. my new Acer Swift 3's battery total went from 100% to 98%!!! I can never charge my laptop to its full potential now! And that is to be expected in any laptop, but the reason why this is such a big problem is because the battery went down in 1 day!! within a day, the total of my new laptop took a hit.

that is why I will use Linux on MY Acer Swift 3 only once Ubuntu 18.04 releases (for stability, but 17.10 will also work) But you are free to go ahead and use risky software and kernels.

LINK for Ubuntu ISO with mainline kernel -> http://linuxiumcomau.blogspot.com/2017/06/interim-ubuntu-1704-iso-with-mainline_29.html

TIP - Install That ISO, and upgrade its Mainline kernel to the latest, or at least to 4.12, because it comes with 4.12RC7.

Or maybe try an "unstable" Ubuntu kernel, but be warned, battery life takes a hit when using these kernels, so remember to use TLP ;) Good Luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .