2

BQ Aquaris E5 running ubuntu touch. My phone worked fine until this morning. But now, the screen does not respond to touch. I tried restarting it, that didn't help either. The volume and the power buttons work fine. Since the phone is locked, I can't even connect it to PC.

  • maybe it's a hardware problem? – Sumeet Deshmukh Apr 26 '17 at 8:31
  • Thanks. It could be. The phone responds during fastboot, though. I have tried factory reset, except that now I'm practically locked out of the phone and it can't even update automatically on wi-fi, since that would require me to work through the screen, which does not respond. Is there a way to reload the complete software bypassing screen use (just curious)? – Abhishek Apr 26 '17 at 20:07
  • @Abhishek screen responds in fastboot? is it a touchscreen bootloader? – Yoginee Pingale May 7 '17 at 12:27
  • No, the touchscreen doesn't respond in fastboot. I meant the phone updates and I could "factory reset" it. – Abhishek May 7 '17 at 12:31
  • I might have to go for an android phone now, or use android on the BQ E5. Whatever happens first. That, unfortunately, would be a heartbreak. – Abhishek May 7 '17 at 12:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.