I own a Sony VAIO VPCEA35FL Laptop, and I'm having problems burning CDs/DVDs. It seems that the burn process itself works, but once the disc is done, it can't be played. I tried Brasero and k3b, both without success. Sometimes the TOC can be read without a problem, but the data never is readable. Also, when I try to play video DVDs, the dvd drive becomes noisier and usually the video stops for a few seconds. This is a weird behavior, since a couple days ago I was using another O.S. and it worked just fine.

I think that this wasn't a problem using Natty.

What can I do?


First, test your laptop's cd/drive. Insert some running(new is better) disk(cd and dvd) and ensure that it can read/run each disk successfully.

Second, Check disk speed in brasero/k3b before burn the disk. Set disk speed(Dvd : 8X and cd/mp3: 24X). Do not multi-task during burning. That means leave your laptop alone during burning process running.

Edited Version:

I tried Brasero and k3b, both without success

What is the error message that brasero or k3b shows?

Again about burning process, after burn dvd brasero automatically eject the drive or shows a warning "Eject the cd drive manually". So if it will not automatically eject then just eject manually.(it is not a major task but should done).

If you can open your written dvd(i know data is not readable) then provide the output:

ls -l /media/cdrom0

What kind of output shows if you do this:

cp -a /media/cdrom0/anyfile anyfile
| improve this answer | |
  • That's what I did.. I was about to take my PC to warranty, so I installed windows back, and then I tried to burn a CD, which burned perfectly. I never burn discs at full speed, and those times I wasn't multitasking.. – Padlite Dec 27 '11 at 2:25
  • Sorry for the late response, I didn't know you edited the post.. Burning process ends correctly, but data isn't readable. I inserted a bad-burned disk and it doesn't even get mounted. So /media/cdrom0 isn't available. – Padlite Jan 4 '12 at 11:01
  • can you read other dvds (not burned by you) without any problem? Is this problem start after fresh install ubuntu? – shantanu Jan 4 '12 at 19:11
  • I can read disks with Ubuntu. I noticed that playing a certain video DVD it cuts several times (like every 5 minutes), it buffers a bit and it starts playing again. I'm not quite sure if it was the disk itself or the drive. This happened on VLC, Totem and XBMC. – Padlite Jan 5 '12 at 0:31
  • To solve your problem i need to know how did your problem start. Did you ever burn dvd successfully in ubuntu?. OR this problem start after install something or change in your system.? – shantanu Jan 5 '12 at 7:20

it could be the back-end it uses which is probably cdrkit, you can read more about it here

you could replace it with a ppa

| improve this answer | |
  • You posted the same answer elsewhere. You should rather vote/flag to close as duplicate, or, if the question is not a duplicate, tailor the answer to this specific question. Note that posting the same link in many answers can be considered spamming. – Melebius Apr 26 '18 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.