0

I notice pip3 is broken unless run by sudo; even after trying to purge & reinstall:

sudo apt-get purge python3-pip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-src python3-wheel
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED
  python3-pip*
0 to upgrade, 0 to newly install, 1 to remove and 67 not to upgrade.
After this operation, 569 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 394962 files and directories currently installed.)
Removing python3-pip (8.1.1-2ubuntu0.4) ...
Processing triggers for man-db (2.7.5-1) ...

where pip3
pip3 not found

sudo apt-get install python3-pip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  golang-1.6-go golang-1.6-src
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed
  python3-pip
0 to upgrade, 1 to newly install, 0 to remove and 67 not to upgrade.
Need to get 0 B/109 kB of archives.
After this operation, 569 kB of additional disk space will be used.
Selecting previously unselected package python3-pip.
(Reading database ... 394889 files and directories currently installed.)
Preparing to unpack .../python3-pip_8.1.1-2ubuntu0.4_all.deb ...
Unpacking python3-pip (8.1.1-2ubuntu0.4) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up python3-pip (8.1.1-2ubuntu0.4) ...

pip3
Traceback (most recent call last):
  File "/usr/bin/pip3", line 9, in <module>
    from pip import main
  File "/usr/local/lib/python2.7/dist-packages/pip/__init__.py", line 28, in <module>
    from pip.vcs import git, mercurial, subversion, bazaar  # noqa
  File "/usr/local/lib/python2.7/dist-packages/pip/vcs/subversion.py", line 9, in <module>
    from pip.index import Link
  File "/usr/local/lib/python2.7/dist-packages/pip/index.py", line 31, in <module>
    from pip.wheel import Wheel, wheel_ext
  File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 6, in <module>
    import compileall
  File "/usr/lib/python3.5/compileall.py", line 20, in <module>
    from concurrent.futures import ProcessPoolExecutor
  File "/usr/local/lib/python2.7/dist-packages/concurrent/futures/__init__.py", line 8, in <module>
    from concurrent.futures._base import (FIRST_COMPLETED,
  File "/usr/local/lib/python2.7/dist-packages/concurrent/futures/_base.py", line 381
    raise exception_type, self._exception, self._traceback
                        ^
SyntaxError: invalid syntax

python3 --version
Python 3.5.2

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.2 LTS
Release:        16.04
Codename:       xenial

sudo pip3

Usage:   
  pip <command> [options]

Is that by design that I need to use sudo to run pip3?

p.s. I can't create pip3 tag due to points but feel free to retag as pip3

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.