0

I am on Ubuntu 16.04 and with gcc-5.4.0 already installed.

I am trying to build the gcc-3.2 compiler according to this tutorial as I need it to compile glib-1.2.10, to build gtk-1.2.10, to run phoebe-0.29d astronomy software.

During the make command step of building the gcc-3.2 compiler, I get the following errors:

Makefile:3282: recipe for target 'read-rtl.o' failed

make1: *** [read-rtl.o] Error 1

make1: Leaving directory '/home/bart/gobj/gcc'

Makefile:1601: recipe for target 'all-gcc' failed

make: *** [all-gcc] Error 2

According to this tutorial, I have to apply two patches (gcc-3.2.patch and the gcc-3.2-nofixincludes-2.patch) that resolve issues with incompatibility of macro commands between gcc versions, but there is no link for the second one that I can find.

Any help applying the patches or building 'gcc-3.2' would be much appreciated.

  • 2
    The patches are here - oss.sgi.com/LDP/LDP/lfs/html/chapter03/packages.html – Panther Apr 18 '17 at 17:39
  • Hi, thanks for the immediate response. Unfortunately none of the patches can be downloaded because it says they don't exist. I tried the http links and also to wget the ftp but with the same result. – KosZer Apr 18 '17 at 22:19
  • Also i found this link linuxfromscratch.org/patches/downloads/gcc and lucky me but only the gcc-3.2 patches seem to do not exist :P . Maybe i could try to install the gcc-2.95.3 because there are some files as patches but there isn't a guide and i'm not sure if they are for the same purpose i'm looking for. – KosZer Apr 18 '17 at 22:29
0

Easier : Get the old packages.deb → 1) gtk+1.2 → http://old-releases.ubuntu.com/ubuntu/pool/main/g/gtk+1.2/ ... 2) glib1.2 → http://old-releases.ubuntu.com/ubuntu/pool/main/g/glib1.2/

Or use the patches : glib1.2_1.2.10-17build1.diff.gz, gtk+1.2_1.2.10-17build1.diff.gz from the links to compile with a later compiler. I just did with gcc-4.9.2 ( Took a minute each ). May also be possible with Ubuntu 16.04 . Available for 16.04 are : sudo apt install gcc-4.7 gcc-4.8 gcc-4.9


Howto build : ( But I would just install the two packages_amd64.deb )

cd glib-1.2.10/
zcat glib1.2_1.2.10-17build1.diff.gz | patch -p1
export CC=gcc-4.9 && ./configure --prefix=/usr
make && sudo make install

cd gtk+-1.2.10/
zcat gtk+1.2_1.2.10-17build1.diff.gz | patch -p1
export CC=gcc-4.9 && ./configure --prefix=/usr
make && sudo make install

Be aware that you may have to use an earlier version of gcc in Ubuntu 16.04 : sudo apt install gcc-4.7 . The export commands are then export CC=gcc-4.7

  • Hey thanks a lot for your response! I installed the gcc-4.9.2 but could you please tell me which commands to use exactly in order to patch the glib and gtk+ with the .diff files ? Also for the sake of completeness the .deb files of the easier way i have to use are: libglib1.2_1.2.10-17build1_amd64.deb and libgtk1.2_1.2.10-17_amd64.deb ? – KosZer Apr 19 '17 at 11:32
  • I edited the anwer to include the build of glib-1.2.10 and gtk+-1.2.10 – Knud Larsen Apr 20 '17 at 20:50
  • I really thank you. I managed to install glib1.2 and gtk+1.2 from the deb files, even though in many forums they say that it is incompatible with newer Ubuntu versions. Although, it was needed to install first the glib1.2.deb second the libgtk+1.2-common.deb and lastly (because it has as a dependency the common.deb)the libgtk+1.2.deb. In case someone else needs to install old programms on Ubuntu and needs the gtk+1.2 version it is recommended to install also the glib1.2-dev.deb and gtk+1.2-dev.deb because in that way gtk-config is also installed and needed by old programms. – KosZer Apr 20 '17 at 23:52

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.