My games minimize when I use Steam overlay and open friends chat box. It seems like it prioritizes newly opened window and makes that window active and thus minimizing the game. When you open friends chat Steam open new window on steam overlay and desktop ( they are sync, once you close one of them, the other one also closes). Temp solution is to open the window at the beginning and not to close it, so if I want to chat with someone it just opens new tab not the whole window.

Does anyone know how to prevent this kind of behaviour?


Nope. I also suffer from this. Gnome Ubuntu 17.04, csgo and payday2 minimize when someone talks to me on steam chat and a pop windo appears...

I did find this though: https://steamcommunity.com/app/221410/discussions/0/626329820878430425/:

Thanks for the tip, that got me towards the fix :)

Firstly, this is "by default" behaviour of SDL. It can be disabled in the code by setting SDL_HINT_VIDEO_MINIMIZE_ON_FOCUS_LOSS to 0. It'd be nice if there was a setting for doing so in-game.

However, since we can't edit the code, we have to use a different approach. SDL also recognises environmental variables. So instead of running Civ5 from inside Steam, we run it from the command line. You'll still have to have steam running, first. Then navigate to the directory containing Civ5XP. Then run


Alternately, you can export it in some larger scope.

Actually you can use environment variables in Steam. Right click the game, select properties, then set launch options. Put this in the field:


Then click OK and you're done.

I've avoided this by switching to lxde or xfce. Kde doesn't do this, it's a gnome 3.22 thing

  • You could also apply the variable globally via bash profile or similar – Wilf Jun 12 '17 at 21:38
  • This didn't work for me. I've tried registering the env var at /etc/environment and restating as well. – Gui Imamura May 26 '18 at 20:59
  • This answer is correct, but there is a typo in the code snippets; they say "FOCUS_LOST" when they should say "FOCUS_LOSS." – Zorgoth Apr 7 '20 at 2:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.