7

Pale Moon seems to continue supporting NPAPI plugins like Java indefinitely. I use a website, which require java plugin enabled. But I can't get the java plugin in the plugins list. I know the symbolic link method for Firefox. How to install the plugin in Pale Moon? I'm on Ubuntu 16.04 LTS 64 bit, Java JDK 8u121 and Pale Moon 64 bit

Edit1: After 3 years of asking this question, Java plugin still works fine in Palemoon v28.9.2-1 64 bit on Ubuntu 20.04 LTS. Java version is JRE 8u251 64 bit

Edit2: As of 20th October 2020, Oracle completely removed Java Plugin from 8u271 JRE and JDK packages mentioned in this article. But 8u261 or prior versions works just fine.

6
  • Is there a .so file (or a symlink to it) in the /usr/lib/mozilla/plugins folder? – Gunnar Hjalmarsson Apr 18 '17 at 17:41
  • No, there is no .so file associated with java in that directory. but I've created a symbolic link for the file libnpjp2.so in the directory /usr/lib/firefox-addons/plugins/. Shall I create a link for the same file to the directory /usr/lib/mozilla/plugins ? – La Corazón Apr 18 '17 at 17:48
  • May be worth a try. (I'm really not sure.) – Gunnar Hjalmarsson Apr 18 '17 at 17:53
  • Now you can be 100% sure. It worked. OMG I'm so glad you helped me. Thank You. – La Corazón Apr 18 '17 at 17:54
  • Great! :) Then can you please post the solution as an answer. I think quite a few people will encounter the same problem. – Gunnar Hjalmarsson Apr 18 '17 at 17:58
7

As Gunnar Hjalmarsson said,

To install java plugin in Pale Moon web browser, you have to create a symbolic link of the file libnpjp2.so to the directory /usr/lib/mozilla/plugins

Here goes the exact terminal command

sudo ln -s /usr/lib/java/jdk1.8.0_121/jre/lib/amd64/libnpjp2.so /usr/lib/mozilla/plugins/libnpjp2.so

If needed, make corresponding changes to the command, if your java version and/or system architecture is different.

Note: Install latest Java JRE/JDK properly before adding symbolic link.

I have verified that the java plugin is working, by going to this page.

I have verified that the java plugin is working

5
  • Odd, PaleMoon 27.3 64bit on 16.04, with Java 1.7 installed, just works! It appears /etc/alternatives is used. root@brix:/tmp# ls -la /usr/lib/mozilla/plugins/libjavaplugin.so /usr/lib/mozilla/plugins/libjavaplugin.so -> /etc/alternatives/mozilla-javaplugin.so root@brix:/tmp# ls -la /etc/alternatives/mozilla-javaplugin.so /etc/alternatives/mozilla-javaplugin.so -> /usr/lib/jvm/java-7-oracle/jre/lib/amd64/libnpjp2.so – Kevin May 2 '17 at 20:24
  • hi kevinf, Java plugin is not working in Pale Moon 27.3.0 64 bit. I'm on Ubuntu 16.04 64 bit and Oracle JDK 1.8.0_131 64 bit. I'm not sure how do I link the java plugin to Pale Moon. In plugins list Java plugin is there, but Java plugin is not working as expected. Your code is a bit confusing, can you explain it a bit further? I already have the plugin file libnpjp2.so in /usr/lib/mozilla/plugins/ and in /usr/lib/firefox-addons/plugins/ and also in /usr/lib/java/jdk1.8.0_131/jre/lib/amd64/. please help – La Corazón Jun 21 '17 at 6:59
  • Please clarify what you mean by not working as expected my instructions were to create the links which you seemingly have – Kevin Jun 22 '17 at 13:24
  • @kevinf I tried to verify Java with this link. The Java applet in java verification page is not loading, which implies Java plugin is not working. In previous Pale Moon version 27.2.1, I created a link using the code sudo ln -s /usr/lib/java/jdk1.8.0_131/jre/lib/amd64/libnpjp2.so /usr/lib/mozilla/plugins/libnpjp2.so. The link is still there, and Java plugin is there in the plugins list, but now Java is not working. So, my question is that, how can I create a link in my system ,inorder to get Java working again. I use Oracle JDK 8u131 64 bit. – La Corazón Jun 22 '17 at 14:16
  • Sorry, I no longer have that test environment / pale moon install. Best of luck :) If the destination of that symlink still exists, then I don't know what to check next. – Kevin Jun 23 '17 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.