7

A few days ago, I installed Ubuntu 17.04 on my Asus laptop dual-boot with Windows 10 and shortly thereafter, I noticed that the systemd-journald process was constantly using 25-35% of CPU.

I traced the process and saved part of the output is at here.

It seems that the CPU is looping, doing something that is related to a pci device.

Does anyone have any advice on the problem?

4

@S_n Can you please check the logs, and see whether it gives indication about the problem?

I've had the same problem and that caused to an infinite loop, and the cpu was constantly higher then 30%.

So if you run in the terminal journalctl you can check it the log in the terminal.

I fixed it by adding a pci=nomsi parameter to the GRUB_CMDLINE_LINUX_DEFAULT property(you can find and edit it in: sudo vim /etc/default/grub)

After adding the parameter update the grub: sudo update-grub and then reboot. Then run top in the terminal, and see whether that fixed it.

Note: By doing that you'll add the parameter permanently, however you can do it temporarily

If you want to add it temporarily, as following:

  1. Start your system and wait for the GRUB menu to show (if you don't see a GRUB menu, press and hold the left Shift key after starting the system).
  2. Now highlight the kernel you want to use, and press the e key. You should be able to see and edit the commands associated with the highlighted kernel.
  3. Go down to the line starting with linux and add your parameter pci=nomsi to its end.
  4. Now press Ctrl + x to boot.
  • 3
    What problem did you have with linux_default_parameter and how did you fix it? You can't just say you have a problem and not say what the fix is. – edwinksl Aug 16 '17 at 20:31
  • 1
    As it stands, this doesn't really seem to answer the question. – sempaiscuba Aug 16 '17 at 21:22
  • My bad, sorry for not doing that. The problem was that a parameter in the grub configuration file was missing, and that caused to an infinite loop, and the cpu was constantly higher then 30%. Therefore I asked can you check what does it say in the terminal, so if you run in the terminal ` journalctl` you'll get a log, and the problem that I faced was described there, and fixed it by adding a pci=nomsi parameter to the GRUB_CMDLINE_LINUX_DEFAULT property, and then update the grub: sudo update-grub and the reboot. I hope that it's more clear now! – Hasan Sh Aug 17 '17 at 8:19
  • @HasanSh You should add that to your answer since some people may not read comments. – edwinksl Aug 17 '17 at 13:31
  • @edwinksl Sure:) – Hasan Sh Aug 17 '17 at 15:57
0

This workaround solved the problem in my computer (Ubuntu 17.10 x64): https://bugs.launchpad.net/ubuntu/+source/gnome-software/+bug/1723362/comments/11

$ sudo apt-add-repository ppa:ubuntu-desktop/gnome-software
$ sudo apt update
$ sudo apt upgrade

The problem is caused by snapd-glib, that logs hundreds / thousands of lines per minute in the /var/log/syslog like these:

Jan 29 11:12:28 hostXXX gnome-software[1723]: Ignoring unexpected response
Jan 29 11:12:28 hostXXX gnome-software[1723]: g_byte_array_remove_range: assertion 'index_ + length <= array->len' failed

My /var/log/syslog got 9.5 Gb of size before update the module and purge the content.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.