1
OS: Ubuntu 16.04

Package expected to install: libsapi

Result: Unable to locate package libsapi

Hi, I am trying to install System API (SAPI) package on Ubuntu 16.04

According to tpm-2.0-tools, in order to build these tools, I need to install this package.

I have been searching around and found out that libsapi is probably the one I am looking for.

However, when I type the following command, it did not give the expected response.

sudo apt-get install libsapi

Where can I find the package or how can I install it?

Thanks


My work-around to do this:

git clone git://anonscm.debian.org/collab-maint/tpm2-tss.git

./bootstrap

./configure

make

make install

If you run this successfully, then you should probably have sapi available now. Switch to the tpm2.0-tools and try again. The error message should go away.

2

It is called libsapi-utils (libsapi-dev) and is in Universe but there is only a version for Zesty (17.04).

You could download the source packages from the links and use gdebi to install it.


Think I found it: libtss2-utils (and libtss2-dev):

xenial (16.04LTS) (utils): TPM2 Software stack library - TSS utilities [universe] 0.98+20160226.d4f23cc-0ubuntu2: amd64 arm64 armhf i386 powerpc ppc64el s390x

So ...

sudo apt-get install libtss2-utils
sudo apt-get install libtss2-dev    

edit: These 2 seem to be built from tpm2-tss (got there from this bugreport). So next attempt:

 sudo apt-get install tpm2-tss
  • When I run configure provided by tpm-tools 2.0, I still got the following error. The packages have been installed. – Sam Apr 18 '17 at 13:11
  • configure: error: Package requirements (sapi) were not met: No package 'sapi' found – Sam Apr 18 '17 at 13:11
  • according to this bugs.debian.org/cgi-bin/bugreport.cgi?bug=815846 (mentions " System API (SAPI)) there is also packages.ubuntu.com/source/xenial/tpm2-tss can you install that one too? – Rinzwind Apr 18 '17 at 13:23
  • the same, E: Unable to locate package tpm2-tss – Sam Apr 18 '17 at 13:26
  • do you have universe enabled? Those packages should be there. – Rinzwind Apr 18 '17 at 13:27
1

In Zesty (17.04)

sudo apt-get install libsapi-dev

  • Unable to locate package libsapi-dev, is there anything I might be wrong? – Sam Apr 18 '17 at 13:09
  • @Rinzwind answer suggests that this package is available only for Zesty(Ubuntu 17.04). Try his solution. – Kishlay Kumar Apr 18 '17 at 13:12
  • Here tpm2-tss for xenial seems to be deleted if you were trying that. – Kishlay Kumar Apr 18 '17 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.