14

Actually yesterday I've upgraded from Ubuntu 16.04 to 17.04 and I got a problem that, if connect LAN cable it does not showing anything and remains disconnected. But i can connect with WiFi. I don't know what's the problem. Actually its showing "device not managed" under the "Ethernet Network" and both were disabled. I've searched for the solution, but did not found yet.

  • 1
    I'm having the same problem, I did what was suggested but still don't see the ethernet connection nor does it connect, it connects to the wifi fine. the light is on with the cable connected. I restarted the laptop and it still isn't there. Worked find in 16.04 – casawyer Apr 25 '17 at 5:55
  • 1
    This seems duplicate of another question. See answer askubuntu.com/a/909648/170833 should solve this same problem too (I had same problem with ethernet cable on a computer that had it, and also with a USB type C dongle with ethernet on a second computer without 'native' ethernet) – morhook Apr 30 '17 at 23:47
  • 1
    This is Ubuntu bug #1676547, please consider providing information that will help fixing the bug there (but not "me, too" style commentary). Thanks. – Tom Oct 8 '17 at 8:00
22

Here is the fix for the LAN problem that first occurred mildly in 16.04, got a bit worse in 16.10 and became unbearable in 17.04 rendering it unusable:

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo service network-manager restart

This creates a blank file needed in the /etc/NetworkManager/conf.d directory which the installer fails at creating automatically. The real question that should be asked is why are such critical things left unresolved for so long to cause needless worry and lost time for many people?

UPDATE: In addition to the above, the culprit seems to be the file with the same name in /usr/lib/NetworkManager/conf.d/. Either comment out (by inserting a hash at the beginning of each line) or delete all its contents to make it a blank file using a text editor such as gedit:

sudo tee /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf < /dev/null

Alternatively, backup the existing file, and add e.g. _backup to its name to be safe, and create a new blank file. I actually went back to 16.04LTS for a while due to this problem, but now the networking is functional under 17.04.

| improve this answer | |
5

Most probably your interface appears in /etc/network/interfaces. By default, NetworkManager does not manage interfaces that appear in /etc/network/interfaces. You can change this behaviour.

To do this - in a terminal:

sudo nano /etc/NetworkManager/NetworkManager.conf

change the line managed=false to managed=true

Save, stop and start network manager:

sudo service network-manager restart

EDIT 1

Try this. Remove the interface from /etc/network/interfaces.

backup the current interfaces file:

sudo cp /etc/network/interfaces /etc/network_interfaces_backup

Then open the file:

sudo nano /etc/network/interfaces

Delete everything in that file and copy and paste the following:

 auto lo
 iface lo inet loopback

Save, stop and start network manager:

sudo service network-manager restart

After this check that you have Enabled Networking ticked

| improve this answer | |
  • By default, its true on my PC, see here: s7.postimg.org/uxs8ozwx7/… The thing is, its showing "device not managed". And I've searched a lot on google, still no use! – RuD3B0y Apr 18 '17 at 9:18
  • 2
    I'm having the same problem with my HP-15 after upgrading to 17.04, I did what was suggested and still no ethernet connection showing or active. – casawyer Apr 25 '17 at 6:56
  • 1
    I add EDIT 1 to my answer. – 2707974 Apr 25 '17 at 7:21
  • 1
    Changing managed from =false to =true seemed to have worked for me, It seems to be intermittent so I will see. I run a VPN with OpenVPN so this may be an issue with 17.04. – EODCraft Staff May 4 '17 at 10:42
  • 1
    This answer worked for me. I understand that the other (most voted) may work for other scenarios but in my specific case this solved it. Thanks. – eburgos Sep 28 '17 at 2:34
1

This solved my problem. Edit this file:

sudo -H gedit /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf

You need to explicitly add ethernet devices to be managed. To do so the contents of the file should be like this:

[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan,except:type:ethernet

After that, just restart the NetworkManager service:

sudo service network-manager restart
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.