2

I have a serious issue after upgrading from Ubuntu 16.10 to 17.04.

My machine is connected to wifi and IP address is obtained. But there is no internet connection.

Everything was working fine before the upgrade.

In /var/log/syslog I can see many DNSSEC validation failed messages.

I tried this, but did NOT help:

[device]
wifi.scan-rand-mac-address=no

Then restart network-manager

6
  • Thank you for the bug report. It would be great if someone can suggest me a solution. Anyway I do not kow how to install the bugfix later because there is no internet connection on my laptop... – zappee Apr 17 '17 at 22:08
  • Could be related: ubuntu.com/usn/usn-3259-1. Update is available. @zappee Nothing works like a cable. – mikewhatever Apr 17 '17 at 22:26
  • How to install any fix without internet connection? – zappee Apr 17 '17 at 22:40
  • I just swapped my ralink usb for a realtek usb, and everything came to life! All I had to do was re-enter my wi-fi passcode. – Robert Milnes Jul 18 '17 at 0:23
2

Here is a link of the bug.

And here is what you should try:

Open a terminal and type or paste this and run it:

sudo -H gedit /etc/NetworkManager/NetworkManager.conf

Then edit the file and add these lines to the bottom of the file:

[device]
wifi.scan-rand-mac-address=no

Save the file and run this command in a terminal:

sudo service network-manager restart

EDIT: Sorry, just read your edit to your question.

Try this line of code(it fixed my internet in 16.10 and 17.04:

sudo killall dnsmasq
0
4

As written here, create the file /etc/systemd/resolved.conf.d/no-dnssec.conf with the following content:

[Resolve]
DNSSEC=no

And restart. I tried the scan-rand-mac-address thing and adding 8.8.8.8 as DNS, but that was the only thing that worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.