I upgraded to Ubuntu 17.04 from 16.10 yesterday on my HP Spectre x360 13-w0XX. After upgrading, I noticed that the sound wasn't working anymore: the volume sliders in the menu bar were grayed out, pressing the volume increase/decrease hotkeys didn't do anything, and there was no sound output.

I followed some online guides about the same question and found that the audio card is being identified, and I can select an audio output in system preferences (see below).

After running sudo update-initramfs -u and rebooting, the volume sliders are no longer grayed out and the speakers work, but there is no sound when I plug in headphones.

Having been through many online guides, I don't really know where to go from here, so any help is appreciated.

Here is some additional information:

The volume is not muted on alsamixer.

I followed this guide, to no avail. Here is is the output of sudo aplay -l:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and here is the output of lspci -v | grep -A7 -i 'audio':

00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21) (prog-if 80)
    Subsystem: Hewlett-Packard Company Device 827e
    Flags: bus master, fast devsel, latency 32, IRQ 286
    Memory at dc228000 (64-bit, non-prefetchable) [size=16K]
    Memory at dc200000 (64-bit, non-prefetchable) [size=64K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel, snd_soc_skl

This is the result of running wget http://www.alsa-project.org/alsa-info.sh -O alsa-info.sh && chmod +x alsa-info.sh && ./alsa-info.sh

Update: opening a Windows 10 VM in Ubuntu 17.10 shows a volume icon with a red X on it. I can fix the speakers in the VM using Windows troubleshooting, but it says that headphones are not plugged in while troubleshooting (they are plugged in).

I used grep "pulseaudio" /var/log/syslog* and got this output:

pulseaudio[1385]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
pulseaudio[1880]: [alsa-sink-Generic Analog] alsa-mixer.c: Failed to set switch of Headphone: Input/output error
  • Any success with this? I'm having a very similar issue after upgrading to 17.04 on a Dell XPS 13 (9350). Edit: I have volume controls, but Sound settings are showing a "Dummy Output". – amiuhle Apr 22 '17 at 17:42
  • Unfortunately not. I tried playing around with it, but I'm not sure if Alsa has to release a new version compatible with my laptop and Ubuntu 17.04 or if something else is going wrong. I'm considering downgrading until there is a better solution. – daladier Apr 22 '17 at 21:15

Had the same problem and found that the following worked (from https://ubuntuforums.org/showthread.php?t=2360020)

Add the following line to /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=basic

and restart alsa with sudo alsa force-reload.

  • Also working on a Dell Latitude 3580. – MikaelF Feb 8 at 18:39
  • I suspect this worked for me, on a Dell XPS 13, many thanks! – PlasmaBinturong Mar 9 at 21:30

In Ubuntu 17.04, I opened a terminal window and typed in pulseaudio and pressed enter and within a few seconds, the "greyed-out" speaker icon on the right side of the top bar became "black" (i.e. not greyed-out) and the sound started working. Seems weird but I have to do this every time I start up this computer (a Dell Optiplex 760). It's a pain in the ass but it works for me. I hope this helps people out.

  • I have since migrated from Ubuntu, though my headphone jack still doesn't work. When I did try it again, the speakers were working. Instead of running pulseaudio each time, maybe running sudo update-initramfs -u will fix it, and if not, try updating drivers on Windows and/or reinstalling Ubuntu. – daladier Sep 7 '17 at 7:25
  • If you run pulseaudio -D, it will run it as a daemon. This SO answer has more detail. askubuntu.com/a/15224/6156 – enobrev Sep 21 '17 at 9:56

I had similar issues, and I found that pulseaudio was dying and restarting in a loop.

I saw in /var/log/syslog that pulseaudio was missing some modules it expected. After searching the web for what package provides mbeq_1197.so, I installed the swh-plugins package, and suddenly my volume controls reappeared and I had audio.

  • 1
    Thanks for your reply. I installed swh-plugins, but unfortunately, it didn't fix my problem. Audio through speakers works as before, and there is still no output through headphones. – daladier Apr 19 '17 at 2:18

My solution: changed from Gnome desktop back to Unity desktop after reboot and sound resumed working. I upgraded from 16.04 to 17.04 with a few minor bugs that already had solutions available. Later, I decided to try the Gnome desktop after reading it was the new direction just to see how it worked. Today is the first day I used something that required sound - no sound. On a whim I flipped back to Unity and sound now works again.

  • That's really odd because sound is handled by ALSA and PulseAudio, neither of which depend on Gnome or Unity desktop components. The latter just provide interfaces to monitor and instrument the formers. – David Foerster May 21 '17 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.