I am trying to share my wireless connection with my XBox 360 (which does not have a wireless adapter) via ethernet cable. I thought there once was a sharing option in Network Manager (it has been some time since I've last used Ubuntu) but it appears to be conveniently removed. I've looked and looked across endless results in Google on the subject and they all seem to point to using this missing option.

Since they seem to have broken Ubuntu 11.10 in so many ways, how can I configure this manually? I've tried switching to XFCE but it still uses the same application when I go to edit connections.


Set it to share as per below. It's not able to get a connection. The XBox connection test dies before the Network icon. Also, to make it more interesting, the wireless connection disconnects and reconnects in rapid succession as long as sharing is enabled.

  • Do you have two network ports on your computer (eg one wireless, one wired or two wired?). Then you can either bridge the connection or turn your computer into a router. The bridge is the technically more elegant solution but may require more set up. Alternatively buy a cheap switch and plug your computer and the Xbox into it (assuming you have a wired connection on your computer): the switch is essentially a bridging device. – adrianmcmenamin Dec 26 '11 at 19:10
  • My laptop is wirelessly connected to the router, and I'm plugging the XBox to the laptop with an ethernet cable. It worked perfectly fine in Windows so I know the hardware is all good. I didn't want to fork over the extra cash for a wireless adapter for the XBox, especially seeing as their effectiveness seems ambiguous, taking all of the reviews into account. – Dissident Rage Dec 27 '11 at 16:40
  • See also [Wired Connection shared with other computers connects then disconnects in 11.10 nm-applet][1] [1]: askubuntu.com/questions/64494/… – LeonardPeris Apr 9 '12 at 13:56

I haven't done this yet on my own, but I think you are searching for this:

enter image description here


More instructions are available here and here.

  • This is probably what I need. I never thought to look there because it seems like it's totally the wrong place for it. I'll try it when I get off work. – Dissident Rage Dec 27 '11 at 16:38
  • Tried it, thanks. Doesn't work, though. The XBox isn't getting a connection. – Dissident Rage Dec 28 '11 at 2:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.