0

I have a ubuntu 16.04, windows 10 asus dual boot. I saw a similar (but not the same) question posted to this one at this link: Intel Centrino Wireless-N 2230 won't connect, keeps asking for password.

My wireless connects but no data is trasnferred, I can't load google, etc. I typed in:

lspci -knn | grep Net -A3

and received:

03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] rev(01)

Subsystem: Lite-On Communications Inc QCA9565 / AR9565 Wireless Network Adapter [11ad:0662]

Kernel driver in use: ath9k

Kernel modules : ath9k

I tried the fixes suggested, but I do not have the /etc/modprobe.d/iwlwifi-opt.conf file, only a /etc/modprobe.d/iwlwifi.conf file. I tried to adapt for atheros vs. intel, but I lack the proper know how.

What should my next steps be?

Thanks.

EDIT 1: I entered the following command as suggested by user nadav mavor:

sudo ifconfig -a ping 8.8.8.8

I received:

SIOCSIFADDR: No such device

ping: Error while getting interface flags: No such device

Edit 2: Corrected the command inputs. I entered:

sudo ifconfig

and received:

enp2s0 Link encap:Ethernet HWaddr 08:62:66:1d:ac

   UP broadcast multicast MTU: 1500 metric:1

   RX packets:0 errors:0 dropped:0 overruns:0 frame:0

   TX packets:0 errors:0 dropped:0 overruns:0 frame:0

   collisions: 0 txqueuelen:1000

   RX bytes:0 (0.0B) TX bytes:0 (0.0B)

lo Link encap:local loopback\

   inet addr:127.0.0.1 Mask:255.0.0.0

   inet6 addr:1/128 Scope:Host

   UP Loopback Running MTU: 65536 metric:1

   RX packets:12 errors:0 dropped:0 overruns:0 frame:0

   TX packets:12 errors:0 dropped:0 overruns:0 frame:0

   collisions: 0 txqueuelen:1

   RX bytes:632 (632.0B) TX bytes:632 (632.0B)

wlp3s0 Link encap:Ethernet HWaddr 18:cf:5e:d2:63:df

   inet addr:10.121.131.95 Bcast:10.121.143.255 Mask:255.255.240.0

   inet6 addr:fe80::cae7:ed2b:584a:84cb/64 Scope:Link

   UP Loopback Running MTU: 1500 metric:1

   RX packets:6002 errors:0 dropped:0 overruns:0 frame:0

   TX packets:3663 errors:0 dropped:0 overruns:0 frame:0

   collisions: 0 txqueuelen:1000

   RX bytes: 8134153 (8.1MB) TX bytes: 421410 (421.4KB)

I entered sudo ping -c2 8.8.8.8 and received:

PING 8.8.8.8 (8.8.8.8) 56(84) byts of data

64 bytes from 8.8.8.8: icmp_seq=1 ttl=59 times=38.4ms

64 bytes from 8.8.8.8: icmp_seq=2 ttl=59 times=13.9ms

--8.8.88 ping statistics

2 packets transmitted, 2 received, 0% packet loss, time 1001ms

rtt min/avg/max/mdev = 13.998/26.201/38.405/12.204 ms

i entered sudo iwconfig and received:

wlp3s0 IEEE 802.11bgn ESSID "internetname"

     mode:managed frequency: 2.412 GHZ Access Point: 84:D4:7e:01:A0

     bit rate=65Mb/s Tx-Power = 17dBm

     retry short limit:7 RTS thr:off Fragment thr:off

     Encryption key:on

     power management:off

     Link Quality=50/70 Signal level=-60dBm

     Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

     Tx excessive retries:0   invalid misc:0 Missed beacon:0

enp2s0 no wirless extensions

lo no wireless extensions

Edit 3: For running sudo cat /run/resolvconf/resolv.con, i receive:

Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

nameserver 127.0.1.1

search "educationalinstitution".edu

  • It will make no good if you try solutions written for Intel to fix your Atheros issue. – Pilot6 Apr 17 '17 at 17:11
  • can you add the output of the follow commands : ifconfig -a ping 8.8.8.8 and iwconfig – Nadav Mavor Apr 17 '17 at 17:12
  • I tried to adapt them as I could. But I didn't know enough. thats why I'm posting here – EMP Apr 17 '17 at 17:13
  • @NadavMavor I enterred your commmands, and wrote the output back in an edit – EMP Apr 17 '17 at 17:19
  • one command at time "ifconfig -a" then "ping -c2 8.8.8.8" and last "iwconfig" all using sudo – Nadav Mavor Apr 17 '17 at 17:36
0

ok its clear that you didn't get DNC from your network the fast and easy was of fix will be to just add by heand :

1) as root edit /etc/resolvconf/resolv.conf.d/base and put

nameserver 10.11.12.83
nameserver 208.67.222.222

it will add 2 name servers to your system (google one and openDNS one )

2) restart your network "/etc/init.d/networking restart"
3) test the new DNS "ping -c2 google.com"

new your system can work and your next step is to talk to your network manager to see why your system do not geting the proper DNS config

  • Thanks! will this fix work when im on other wifi connections? Its been a problem at home and at work (different wifis). thanks again! – EMP Apr 17 '17 at 22:18
  • Hi nadav, this happened again, the file still shows those two servers, but it won't work on a different Wi-Fi now. Is there a permanent fix for This? – EMP May 16 '17 at 18:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.