I'm getting this whenever I go to a new Web page starting a new tab in Chrome

"your connection was interrupted; a network change was detected"

then it proceeds to the page, although often enough it doesn't properly load all of the page.

I've recently upgraded from 16.10 to 17.04 and my Chrome is 57.0.2987.133 (64-bit).

In general, any Chrome browser move (submit, new page) seems hesitant, gets stuck/freezes. Didn't have this problem before the upgrade.

BTW, I found this discussion, but not sure what to do in Ubuntu.


8 Answers 8


Disabling IPv6 seems to have durably resolved the symptoms for me.

(I suspected that IPv6 might be relevant based on this old post https://productforums.google.com/forum/#!topic/chrome/P7qEIWA1__M.)

To check if IPv6 is active, go to the NM panel (wifi symbol near clock) and select Connection Information, like this:

enter image description here

If IPv6 is already ignored or inactive, this answer doesn't apply to you. If IPv6 is active, then disable ("ignore") it in System Settings > Network like so:

enter image description here

Please comment with success/failure so that we can confirm this workaround.

I suspect other network services were unaffected because they use IPv4.

Original post:

I have exactly the same symptoms, browser version, and upgrade path. Firefox does not exhibit similar symptoms. Furthermore, I routinely access other network services (e.g., pypi, mvnrepository) during builds and have no issues there.

The chrome symptoms seem to vary widely. The most frequent symptom (as the OP noted) is the "Your connection was interrupted" error. Other symptoms include missing graphics, incompletely styled pages, and empty content (presumably ajax failures).

That is, the issue is specific to chrome on 17.10, and it affects multiple content types.

  • I just noticed that Austin also associated this with IPv6. I provided this answer too because I think it'll be easier for most folks to implement.
    – Reece
    Apr 19, 2017 at 15:40
  • Yes. This does fixes it. Dec 7 14:07:13 adelsstudio avahi-daemon[4938]: Joining mDNS multicast group on interface vethc6a9ae4.IPv6 with address fe80::ec97:91ff:fef5:7835. Dec 7 14:07:13 adelsstudio avahi-daemon[4938]: New relevant interface vethc6a9ae4.IPv6 for mDNS. Dec 7 14:07:13 adelsstudio avahi-daemon[4938]: Registering new address record for fe80::ec97:91ff:fef5:7835 on vethc6a9ae4.*. Dec 7, 2019 at 1:09

I had this issue too but in my case it was a Docker container going up and down every 10 seconds that made everything behave in a very weird fashion.

Also for the fix above, in case it is IPv6, below is a pure CLI guide.

A pure command line fix instead of clicking in the UI would be:

nmcli device modify wlan0 ipv6.method ignore

Or if you want to do it per connection:

nmcli con modify $CONNECTION_NAME ipv6.method ignore
  • 1
    I didn't think about docker containers, I was apparently (because of restart policy) still running one in network_mode: host , and it was restarting a lot. So far, so good after killing it!
    – Matthias
    Mar 4, 2021 at 10:22

In my case too, it was a Docker issue which was possibly interfering with the internet.

  1. Go to Terminal : (ctrl + alt + T)
  2. Login as sudo user (You need to have admin rights)
  3. Check for running containers : docker ps -a
  4. Remove the containers : docker rm -f <containerID>

I have the same problem and its extremely annoying, look in your /var/log/syslog.

I noticed an overwhelming amount of the same lines being repeated in my log:

avahi-daemon[*]: Registering new address record for My IPV6 Address Here and:

avahi-daemon[*]: Withdrawing address record for My IPV6 Address Here.

It might be normal for some things to repeat in a log but my ipv6 was changing a lot, I mean at least 10 or more times in less than a minute.

Solution.. sort of...

If you have the same lines repeating in your syslog( you can check with this command:

$ grep "avahi-daemon" /var/log/syslog)

The only temporary solution I have found is to disable IPv6. I used this tutorial for 16.04, it still works for 17.04 though: http://www.neuraldump.com/2016/11/how-to-disable-ipv6-in-ubuntu-16-04-xenial-xerus/

p.s. I thought that avahi-daemon was the cause of IPv6 resetting but its not it is just noticing it happen, avahi-daemon deals with mdns. This should save you a good 10-20 min of useless research into the avahi-daemon.

This is just a band-aid it doesn't fix the underlying problem, at some point or another ipv6 will be needed, if I find a TRUE solution I will update this post.

Good luck!

  • (Sort of) great to hear I'm not just imagining this. I'm not a nuts-and-bolts Linuxer, hence, I would have never found this.
    – 147pm
    Apr 19, 2017 at 11:03

I have this issue occasionally, but it's not limited to 17.10:

Version 61.0.3163.100 (Official Build) Built on Ubuntu , running on Ubuntu 16.04 (64-bit)

Disabling IPV6 does seem to eliminate it.


It's hard to know for certain what the causes of the issue might be but based on https://productforums.google.com/forum/#!topic/chrome/P7qEIWA1__M you might simply be able to change your IPv6 privacy settings to Disabled to stop this happening.

See the highlighted box in this image to see where to change it.


I solved the problem by permanently disabling IPv6, take a look at How to disable IPv6 in Ubuntu 14.04?

It worked like a charm for me!


In my case, one of my docker-compose services was restarting rapidly due to incorrect environment variables. I corrected the wrong environment variable, and everything got okay.

So, if you have a running Docker container on your system, please check it to ensure everything is OK.

  • This problem is related to Chrome browser and the Ubuntu 17. May 22 at 17:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .