2

On upgrade to Ubuntu 17.04, AppIndicators for Electron applications are no longer working. I can't see the Discord AppIndicator, for example.

1 Answer 1

7
+100

Run the application with env XDG_CURRENT_DESKTOP=Unity to get the AppIndicator working.

E.g., for Skype for Linux, use the command:

env XDG_CURRENT_DESKTOP=Unity skypeforlinux

To make this fix permanent, go to the application desktop file in /usr/share/applications/, open with Text Editor, select all the text and copy it to a new text file made in Text Editor.


Navigating to /usr/share/applications Opening with Text Editor Copying to a new document


Change the 'Exec' line by adding 'env XDG_CURRENT_DESKTOP=Unity' (without the quotes ('')) immediately after 'Exec=' (don't forget the space after 'Unity'!). Save this in ~/.local/share/applications/.


Adding the env line Saving the new file


Some applications are set to start automatically and in that case, you'll have to edit the desktop file from ~/.config/autostart/ in the same way.

(Note that 'skypeforlinux' should not be in the GIF below!)


Editing that file


Note that some applications overwrite any changes made to their autostart files, located in ~/.config/autostart/. A way around this is to rename the autostart file, then in the application settings, set the application not to start on login. This way, the modified autostart file will be used (which has a different name and contains the workaround).

In the case of Discord, for example, launch it with env XDG_CURRENT_DESKTOP=Unity discord (you'll want to load Discord from the Dash and click File > Exit to close it properly beforehand), then click on the indicator and uncheck 'Run Discord when my computer starts'.

Source
Credit to Peek which I used to make the GIFs, you can get it here.

1
  • 3
    man.. that's a lot of effort that you have put into this answer!!
    – kapad
    Commented Feb 21, 2018 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .