I upgraded to Ubuntu 17.04 and i want to add the y-ppa-manager but when i run the command

sudo add-apt-repository ppa:webupd8team/y-ppa-manager

I get the following error:

gpg: connecting dirmngr at '/tmp/tmp8h5gt_of/S.dirmngr'
failed: IPC 
connect call failed
gpg: keyserver receive failed: No dirmngr
Failed to add key.

But I see that I already have dirmngr. I tried to uninstall and reinstall it but that doesn't work. Can someone tell me what am I doing wrong here?


I figured out that i needed to actually update my gnupg version.
I followed the instructions here and was able to do so.

Trying to compile gnupg from source

Here are the steps:

sudo apt-get update
sudo apt-get install libldap2-dev gtk+-2 libbz2-dev

after unpacking the latest gnupg-2.1.X tarball and cd to the new folder, run the command:

sudo make -f build-aux/speedo.mk native INSTALL_PREFIX=/usr/local
sudo ldconfig

download the latest pinentry-0.9.5, run ./configure && make && sudo make install.

test it out: gpg2 --version

After that you can add the PPA with

sudo add-apt-repository ppa:webupd8team/y-ppa-manager

Download the gnupg tarball from here


Backup your existing directories: $HOME/.gnupg and /root/.gnupg and remove them.

# dirmngr --debug-level guru
dirmngr[20243.0]: error opening '/root/.gnupg/dirmngr_ldapservers.conf': No such file or directory
dirmngr[20243.0]: permanently loaded certificates: 0
dirmngr[20243.0]:     runtime cached certificates: 0
dirmngr[20243.0]: failed to open cache dir file '/root/.gnupg/dirmngr-cache.d/DIR.txt': No such file or directory
dirmngr[20243.0]: creating directory '/root/.gnupg'
dirmngr[20243.0]: creating directory '/root/.gnupg/dirmngr-cache.d'
dirmngr[20243.0]: new cache dir file '/root/.gnupg/dirmngr-cache.d/DIR.txt' created
dirmngr[20243.0]: DBG: chan_3 -> # Home: ~/.gnupg
# Home: ~/.gnupg
dirmngr[20243.0]: DBG: chan_3 -> # Config: [none]
# Config: [none]
dirmngr[20243.0]: DBG: chan_3 -> OK Dirmngr 2.1.0 at your service
OK Dirmngr 2.1.0 at your service
  • Thanks for the answer man but i had a different problem it seems. – Kishlay Kumar Apr 17 '17 at 12:35
  • I use and recommend seahorse Keys and Passwords, for key management, the answer was to address the question. – Steve Hope Apr 17 '17 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.