1

Can't start from GUI. It just won't start, no error message or anything.

When I try from terminal I get:

Loading module: 'libubuntu_application_api_desktop_mirclient.so.3.0.0'
[QPA] QMirClientClientIntegration: connection to Mir server failed.

Mir returned: "Failed to connect to server socket: No such file or directory"

only works when I start it with sudo: sudo qbittorrent

Did they break something again?

By the way, I'm using unity 7.

EDIT: Just noticed Dropbox won't start neither.

1
  • Reinstalling them both and rebooting seems to have solved the problem. Now I have another issue: clicking at the dropbox app icon at the top right (near clock) opens an empty menu.. – Kobi T Apr 17 '17 at 18:15
0

I solved it by installing proprietary NVidia drivers. This of course is not a desirable solution (for instance if one does not have NVidia graphics card). The problem might have something to do with this bug: Multiple apps fail to start, all with the same error message (QPA UbuntuClientIntegration: connection to Mir server failed.)

I say might because apps that failed me all run under Unity7.

I found Calibre and Foxit Reader also failed, but the list could be much larger.

EDIT: Actually before installing NVidia drivers I could launch qbittorrent from a terminal using gksudo qbittorrent which of course does not keep settings or torrents from the normal user. Both the gksudo and the usual qbittorrent under the proprietary NVidia drivers however do not have the native gtk appearance but Qt's Fusion Style widgets, which is weird.

2
  • After installing the NVidia proprietary drivers I switched back to the open-source ones and after rebooting both qbittorrent and calibre work well. QBittorrent still has the Fusion Style widgets. I must admit that before switching display drivers to NVidia and back I did reinstall qbittorrent and calibre, though I didn't reboot. Which means that just reinstalling and rebooting might just do the trick. – Hermes Apr 17 '17 at 19:48
  • Widget style might have something to do with some global QT environment variables not related specifically to qBittorrent or Calibre. – Hermes Apr 17 '17 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.