5

I installed redshift by using the following command in terminal:

sudo apt-get install redshift redshift-gtk

But while running the program i ended up with errors:

enter image description here

So i installed geoclue with the following command:

sudo apt install geoclue

However even after installing geoclue package, I am still facing the same problem.

5
  • Have you tried manually entering your coordinates?
    – mchid
    Apr 17, 2017 at 1:35
  • Do you actually want the screen to change color throughout the day or do you just want one shade of red? If you just want a red tint, you can use the following command: redshift -O 4000K
    – mchid
    Apr 17, 2017 at 1:49
  • @mchid I don't know how to do that in terminal Apr 17, 2017 at 2:48
  • It's as easy as typing a text message. First, press CTRL+ALT+T to open a terminal and then just type the command which is highlighted in grey on my last post, and then press ENTER. You should see a red change in your computer screen.
    – mchid
    Apr 18, 2017 at 3:52

5 Answers 5

7

The problem is not with geoclue package. You don't need to install geoclue. It is because you have not configured Redshift. Redshift sets the color temperature according to your location. The simplest fix to this issue is to enable location services:
System Settings > Security & Privacy > Location services > Turn ON

But you can manually configure Redshift to set custom values for color temperature and location. For that, open up your browser and search for the latitude and longitude for your area, for example, new york latitude and longitude.

Once you get the values for latitude and longitude for your area, then search for Startup Applications in your computer. Most probably you will have the entry for Redshift. Click on the Redshift entry and then click Edit. Then in the command section enter this command:

redshift-gtk -l [LATITUDE]:[LONGITUDE] -t 6500:3400

Replace [LATITUDE] and [LONGITUDE] with your values. For example my command goes like:

redshift-gtk -l 20.5937:78.9629 -t 6500:3400

Note:- If for some reason you don't see the entry for Redshift in the startup applications menu, just click on the Add button instead of the Edit button, provide a name for example, Redshift and then enter the above command.

The values 6500 and 3400 represent the color temperature values for day and night respectively. The value 6500 makes no color changes and the screen is perfectly calibrated. If you want to eliminate blue light on day time also, change the value 6500 to 5500. Again you can have your own custom values. Just Save the settings and Reboot to apply changes.

5
  • On my Ubuntu, there is no Location Services inside Security and Privacy menu. Oct 28, 2017 at 3:23
  • @MadPhysicist Which version of ubuntu do you use? If nothing works out, just add the above command to the startup applications (the method explained above) to manually configure redshift. I actually don't use location services, instead I prefer manually configuring it. The above method is tested and works 100%. Oct 28, 2017 at 14:22
  • I am using 16.04. However, I used your method and it worked :) Oct 28, 2017 at 23:55
  • If you think this answer is helpful, please upvote it. It boosts me up :) Oct 29, 2017 at 16:29
  • I am the one who upvoted it. Cheers! Oct 30, 2017 at 1:16
3

Redshift stopped working in Ubuntu 16.04 (yes, still using it in 2020).

I edited my ~/.config/redshift.conf into the following:

[redshift]
temp-night=4500

location-provider=manual

[manual]
lat=55.953
lon=-3.189

Note: I'm using manual location provider (not geoclue2).

1
  • 1
    This worked for me on Ubuntu 22.04. I just changed the coordinates to my location.
    – Guillermo
    Oct 24, 2022 at 21:15
2

Depending on your window manager you may have to manually allow Redshift to access GeoClue.

Edit GeoClue's config

sudo nano /etc/geoclue/geoclue.conf

Append the following lines to /etc/geoclue/geoclue.conf

[redshift]
allowed=true
system=false
users=

Then restart Redshift kill $(pgrep '[r]edshift*') && redshift-gtk & disown

2
  • This worked for me on 16.04; the answer from Jebin Philipose did not work because there is no setting for Location Services.
    – achiang
    Nov 4, 2018 at 5:10
  • 1
    @achiang I think I have mentioned how to configure Redshift manually in my answer, I'm damn sure 16.04 has Startup Applications Sep 28, 2020 at 15:03
0

I suddenly had this problem after using redshift-gtk for many years without issue. The screen failed to turn red after startup and there was a geoclue error after disabling from the indicator icon menu.

On 18.04, the error is for "geoclue2". However, geoclue-2.0 was already installed on my system. I fixed this by reinstalling the geoclue-2.0 package:

sudo apt update
sudo apt install --reinstall geoclue-2.0
-1
    "redshift - slove geoclue2 redshift not working error" 
#ERROR:
 Trying location provider geoclue2'... Using provider geoclue2'.
 Unable to connect to GeoClue.
 Unable to get location from provider.
 #OR:
  Unable to start GeoClue client:
  GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Geolocation 
  disabled for UID 1000. Unable to connect to GeoClue. 
  Unable to get location from provider.

#solution1) turn on the location:
e.g:
 Gnome Settings > Privacy > location
 #unfortunatly most Desktop environment settings doesn't have location ON/OFF feature, but dont worry, we can install gnome settings manually:
   sudo apt install gnome-control-center
   #then enable location services
    gnome control center > privacy > location services

#solution2) install geoclue2
e.g:
 #on fedora:
  sudo dnf install geoclue2 geoclue2-libs geoclue2-devel geoclue2-demos
 #on debian:
  sudo apt install geoclue-2.0


#solution3) run redshift with sudo
e.g:
 sudo redshift


#solution4) add these lines to  /etc/geoclue/geoclue.conf:
e.g:
 [redshift]
 allowed=true
 system=false
 users=

 #then run:
  sudo service geoclue restart

#solution5) create a configuaration file(THIS SOLUTION WORKED FOR ME)
e.g:
 #YOU NEED TO SET latitude(45th line) and longitude(46th line) manually
  #visit this site the file your lat & lon: https://www.latlong.net/
 #goto ~/.config directory & created a file "redshift.conf" and put below lines in the redshift configuration file(~/.config/redshift.conf)
; Global settings for redshift
[redshift]
; Set the day and night screen temperatures
temp-day=5700
temp-night=3500

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature.
transition=1

; Set the screen brightness. Default is 1.0.
;brightness=0.9
; It is also possible to use different settings for day and night
; since version 1.8.
;brightness-day=0.7
;brightness-night=0.4
; Set the screen gamma (for all colors, or each color channel
; individually)
gamma=0.8
;gamma=0.8:0.7:0.8
; This can also be set individually for day and night since
; version 1.10.
;gamma-day=0.8:0.7:0.8
;gamma-night=0.6

; Set the location-provider: 'geoclue', 'geoclue2', 'manual'
; type 'redshift -l list' to see possible values.
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values.
; 'randr' is the preferred method, 'vidmode' is an older API.
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type 'redshift -l PROVIDER:help' to see the settings.
; ex: 'redshift -l manual:help'
; Keep in mind that longitudes west of Greenwich (e.g. the Americas)
; are negative numbers.
[manual]
lat=48.1
lon=11.6

; Configuration of the adjustment-method
; type 'redshift -m METHOD:help' to see the settings.
; ex: 'redshift -m randr:help'
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the
; second screen. If this option is not specified, Redshift will try
; to adjust _all_ screens.
[randr]
screen=0



#solution6) run redshift in background(if above solutions didn't work? you can try this):
 #remove redshift-gtk extension from panel and stop autostarting redshift in startup programs
 #then add this startup command to run redshift in background after login
   redshift -l 7:81 -t 5700:3600 -g 0.8 -m randr -v
   #you can change 0.8 to adust brightness(0.1 - 1)



#links:
 https://github.com/jonls/redshift/issues/445
 https://askubuntu.com/questions/1061453/redshift-permission-error-gdbus-errororg-freedesktop-dbus-error-accessdenied
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .