Recently I needed to install Ubuntu on my machine. The problem is that I'm getting a low-quality Wi-fi signal.

I'm using a "plug and play" wi-fi connector from TP-LINK: TL-WDN3200(N600).

How can I improve this?

  • Define "low-quality" please Apr 16, 2017 at 21:04
  • Bad quality signal. The signal is weaker.
    – NoOne
    Apr 16, 2017 at 21:08
  • How do you know it's weaker? Judging by the icon or are you experiencing slower download/upload?
    – nullmeta
    Apr 16, 2017 at 21:46
  • Both. Unfortunately. x.x
    – NoOne
    Apr 16, 2017 at 22:01

2 Answers 2


Miraculously, a user from omgubuntu.co.uk had written a comment in one of their articles announcing the release of 17.04 that fixed this issue. The comment is as follows:

wifi and networkmanager

The new NetworkManager release 1.4.0 adds new features to change the current MAC address of your Ethernet or Wi-Fi card (spoofing/cloning). As a debian "sid" user i understand that being on bleeding edge, sometimes new features and configs can be Incompatible with my machine hardware!!! Now being a ubuntu user i can see that Ubuntu is losing his "user friendly" name and no more care for desktop users! This was an unacceptable default config on Ubuntu's best days! Ubuntu haters and criticists must be happy now!

Edit the /etc/NetworkManager/NetworkManager.conf file

And add:


Restart the networkmanager service and use your wireless connection :)"

This worked for me.

  • How do you know OP is using 17.04?
    – Zanna
    Apr 17, 2017 at 16:43
  • It didn't work. x.x
    – NoOne
    Apr 19, 2017 at 2:06

Open a Terminal and enter:

sudo dpkg-reconfigure resolvconf
echo "options rt2800usb nohwcrypt=y" | sudo tee /etc/modprobe.d/rt2800usb.conf 
sudo modprobe -rfv rt2800usb
sudo modprobe -v rt2800usb
sudo service network-manager restart

Source: Ubuntu Forums thread

  • how do you know this will work? Wireless problems are hardware specific
    – Zanna
    Apr 17, 2017 at 16:44
  • Why this should work? Can you explain? I'm using ubuntu 16.04 btw.
    – NoOne
    Apr 19, 2017 at 2:08
  • Update: I did this and removed what johnconnorfx suggested. The connection improved a lot. Not as good as my previous SO, but I had a nice improvement. Thanks!
    – NoOne
    Apr 23, 2017 at 2:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.