5

I tried to install opera by downloading the .deb file from opera website. Running sudo dpkg -i opera-stable_44.0.2510.1218_amd64 gave the following results:

[sudo] password for user1: 
(Reading database ... 187300 files and directories currently installed.)
Preparing to unpack opera-stable_44.0.2510.1218_amd64.deb ...
Unpacking opera-stable (44.0.2510.1218) ...
dpkg-deb (subprocess): decompressing archive member: lzma error: compressed data is corrupt
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive opera-stable_44.0.2510.1218_amd64.deb (--install):
 cannot copy extracted data for './usr/lib/x86_64-linux-gnu/opera/opera' to '/usr/lib/x86_64-linux-gnu/opera/opera.dpkg-new': unexpected end of file or stream
Processing triggers for bamfdaemon (0.5.3+17.04.20170406-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu5) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Processing triggers for shared-mime-info (1.8-1) ...
Processing triggers for menu (2.1.47ubuntu1) ...
Errors were encountered while processing:
 opera-stable_44.0.2510.1218_amd64.deb"

Opera is currently not available in Ubuntu software store or in Software Boutique. I also tried older opera-stable_44.0.2510.857_amd64.deb and got similar results. I downloaded the package twice thinking it might be any download error but same result.

  • Test this one: dpkg --force-all -i opera-deb-file – Ravexina Apr 16 '17 at 18:30
  • lzma error: compressed data is corrupt and unexpected end of file or stream strongly suggest the file is indeed corrupt. – user589808 Apr 16 '17 at 19:18
  • @CelticWarrior How do i download one that is not corrupt? Previously when i update using sudo apt get update command there used to be lots of weak hash values. Does this all mean there is some problem with my Internet connection? – dipu Apr 16 '17 at 19:27
  • Either that or a problem in the drive you're saving the files. – user589808 Apr 16 '17 at 19:28
  • @CelticWarrior Downloads are on ext4 partition, then i move it to NTFS for storage. Installation is done on NTFS drive. Hard disks are relatively new. One is less than 3 years old and other is new one. – dipu Apr 16 '17 at 19:32
2

Try this:

Open a terminal,

Press Ctrl+Alt+T

Run it:

exec sudo -i
nano /etc/apt/sources.list.d/opera-stable.list

In the file that opens, paste this text:

# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)

Ctrl+O

Save file.

Ctrl+X

Close nano.

Continue running in the terminal:

wget -O - http://deb.opera.com/archive.key | apt-key add -
apt-get update
apt-get install opera-stable
  • Here are the main results "Reading package lists... Done W: GPG error: deb.opera.com/opera-stable stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 63F7D4AFF6D61D45 W: The repository 'deb.opera.com/opera-stable stable InRelease' is not signed. N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use. N: See apt-secure(8) manpage for repository creation and user configuration details. E: Failed to fetch in.archive.ubuntu.com/ubuntu/dists/zesty Hash Sum mismatch – dipu Apr 17 '17 at 18:02
  • E: Failed to fetch in.archive.ubuntu.com/ubuntu/dists/zesty E: Failed to fetch in.archive.ubuntu.com/ubuntu/dists/zesty E: Some index files failed to download. They have been ignored, or old ones used instead. – dipu Apr 17 '17 at 18:03
  • root@PC1:~# apt-get install opera-stable Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: – dipu Apr 17 '17 at 18:05
  • 1
    Still not able to install. Thanks for the help any way. – dipu Apr 17 '17 at 18:07
  • 1
    Try this: " exec sudo -i " " wget -O - deb.opera.com/archive.key | apt-key add - " " apt-get -f install " " apt-get install opera-stable " – kyodake Apr 19 '17 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.