0

I am not getting any updates since 2 weeks. Whenever i open the update manager it shows that the computer is up to date. When i try to run update manager through the terminal i get these errors:

(update-manager:5052): Glib-CRITICAL **: g_hash_table_destroy: assertion 'hash_table != NULL' failed

(update-manager:5052): Glib-CRITICAL **: g_hash_table_destroy: assertion 'hash_table != NULL' failed

Error while running update manager

output of sudo apt-get update && sudo apt-get dist-upgrade

Edit: I am also getting errors when I run sudo ubuntu-support-staus. Error messages:

Traceback (most recent call last):
  File "/usr/bin/ubuntu-support-status", line 133, in <module>
    pkg.name, support_tag)
  File "/usr/bin/ubuntu-support-status", line 49, in get_maintenance_status
    raise Exception("No date tag found")
Exception: No date tag found

Please help Thanks :)

  • In terminal do sudo apt-get update && sudo apt-get dist-upgrade. Please edit and post the error messages, if any, in its entirety. – user589808 Apr 16 '17 at 15:12
  • I don't get any error messages by running these commands but the problem still persists – srijan bhatia Apr 16 '17 at 15:16
  • Did it installed any updates? – user589808 Apr 16 '17 at 15:18
  • Sorry for the delay i have edited the question with some screenshots – srijan bhatia Apr 16 '17 at 15:31
  • No it doesn't install any updates – srijan bhatia Apr 16 '17 at 15:31
0

srijan,

Try running sudo apt-get clean all followed by sudo rm -rf /var/cache/apt/* then proceed with sudo apt-get update && sudo apt-get dist-upgrade . Something could be jacked due to a lock file or the cached files. Also make sure there are no other dpkg or apt processes running already before you start :)

Let us know.

  • Ran all these commands. Still no progress. – srijan bhatia Apr 17 '17 at 4:45
  • So..... I missed the last four posts above. CelticWarrior is right about running update-manager and ubuntu-support-status commands in that they are not relevant to what you really want is patches being applied to your machine. – wedgeshot Apr 18 '17 at 11:52
  • Yeah I found a patch in this bug report Bug. Thanks for helping out – srijan bhatia Apr 18 '17 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.