1

I'm trying to install WPS office in Ubuntu Gnome 17.04 , the installation through the Software App is not working (By unknown reasons at least by me) I've been able to install other software but not WPS office, so I tried with the command to install .DEB packages and it outputs the next error:

sudo dpkg -i wps-office_10.1.0.5672-a21_amd64.deb


(Reading database ... 216574 files and directories currently installed.)
Preparing to unpack wps-office_10.1.0.5672-a21_amd64.deb ...
Unpacking wps-office (10.1.0.5672~a21) ...
dpkg-deb (subprocess): cannot copy archive member from 'wps-office_10.1.0.5672-a21_amd64.deb' to decompressor pipe: unexpected end of file or stream
dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive wps-office_10.1.0.5672-a21_amd64.deb (--install):
 cannot copy extracted data for './opt/kingsoft/wps-office/office6/libwppcore.so' to '/opt/kingsoft/wps-office/office6/libwppcore.so.dpkg-new': unexpected end of file or stream
Processing triggers for gnome-menus (3.13.3-6ubuntu5) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for shared-mime-info (1.8-1) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
 wps-office_10.1.0.5672-a21_amd64.deb

Thank's before hand , if someone has already solved this problem I would be glad to know how , this can help other people as well, thanks.

  • Unfortunately WPS for Linux seems to have been abandoned -> No updates since last year. For comparison, the Windows version is currently at 10.2.0.5820 – January 23 2017. Really sad and I'm afraid it's game over. The last version for Linux works in 16.04/16.10 but requires an additional library. – user589808 Apr 16 '17 at 5:56
  • Oh , I didn't know it , that's really sad , I guess I will have to get used to Libre Office – Angelo Giuseppe Apr 16 '17 at 5:57
  • I'll try to contact Kingsoft. Currently there's official announcement. The forum seems to be abandoned as well an has been a freaking SPAM orgy for years. – user589808 Apr 16 '17 at 6:03
  • 1
    Okay man , I'll try as well , it was a cool office suite – Angelo Giuseppe Apr 16 '17 at 6:10
  • 1
    man , seriously thank you , it freaking worked , you can post an answer with your link and I'll mark it as right so this can help other people – Angelo Giuseppe Apr 16 '17 at 7:05
2

WARNING: This answer may became obsolete anytime soon. WPS for Linux seems be have been abandoned. The version you have is the last one and it may not be installable in newer Ubuntu releases.

The original error message - unexpected end of file or stream - suggests corrupt download. This has been confirmed with the checksum.

Download from my personal share and confirm SHA1 matches 80d884c47eaeee3305958ed87e61eafbee30b0cf.

Before installing, due to a missing dependency since 16.10, this workaround is still required. You should now be able to install and enjoy this great office suite that unfortunately reached the end of its life.

  • 1
    alternative link: app.box.com/s/f5pp05570oq9j4jac6r35xzgy35g42ww – Angelo Giuseppe Apr 16 '17 at 7:26
  • Just for the record, I've just downloaded the file and the SHA matches. Might have been a temporary server issue or something similar. – Kaz Wolfe Apr 16 '17 at 21:21
  • @KazWolfe That's probably it. When I downloaded (with DownThemAll) I had to pause and restart 3 times. Kingsoft's servers were never that good. Years ago it would takes hours, literally. – user589808 Apr 16 '17 at 21:28
2

Using gdebi (instead of dpkg) as manual package installer, it gives you the error that the libpng12-0 package is missing.

This package shall be downloaded following those links :

http://packages.ubuntu.com/xenial/i386/libpng12-0/download

http://packages.ubuntu.com/xenial/amd64/libpng12-0/download

(according to this Ask Ubuntu thread)

Then install this package with dpkg (gdebi raises an error ...). In my case :

sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb

And finally install WPS :

sudo dpkg -i wps-office_10.1.0.5672~a21_amd64.deb

And normally WPS is installed and works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.